summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-11-07 21:03:40 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-11-07 21:03:56 +0100
commitc57fa0c646c95b896f24d3054013484c865aeedf (patch)
tree1fd9c1660a451789ac5c5e74dc4b746e52d67b29 /sci-libs
parentnet-im/discord: Fix system log spam on Wayland (diff)
downloadgentoo-c57fa0c646c95b896f24d3054013484c865aeedf.tar.gz
gentoo-c57fa0c646c95b896f24d3054013484c865aeedf.tar.bz2
gentoo-c57fa0c646c95b896f24d3054013484c865aeedf.zip
sci-libs/onnx: add 1.16.2
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/onnx/Manifest1
-rw-r--r--sci-libs/onnx/onnx-1.16.2.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sci-libs/onnx/Manifest b/sci-libs/onnx/Manifest
index 5b59ba271455..00f196c30f46 100644
--- a/sci-libs/onnx/Manifest
+++ b/sci-libs/onnx/Manifest
@@ -1 +1,2 @@
DIST onnx-1.16.1.tar.gz 12428832 BLAKE2B 15a7db2fa263914957c671bd8e94eb8b80afeba0b396e8b54f8fb2deda2965885055efae7a6f6e402eb085b5795025020f650132023ba3d4df1f395d99ec353c SHA512 0ae1b36563ddeaa9947bf452eb20b83174e4c2bc4696b61768f096c401666323343fac0f699f756da99d3c29df15a0bd78fe3fa51da15f133617d7310c5b28d4
+DIST onnx-1.16.2.tar.gz 12429500 BLAKE2B 1541fd9e80e305bc0764d1f5d236a89a2f0d0d8819bd6f235c88d35985daf02f575854a537af193befbeab861b2fe6a9d5b8803975b8ae6a47d5d5a6dc28b661 SHA512 7a9a8493b9c007429629484156487395044506f34e72253640e626351cb623b390750b36af78a290786131e3dcac35f4eb269e8693b594b7ce7cb105bcf9318d
diff --git a/sci-libs/onnx/onnx-1.16.2.ebuild b/sci-libs/onnx/onnx-1.16.2.ebuild
new file mode 100644
index 000000000000..0e8227eb2487
--- /dev/null
+++ b/sci-libs/onnx/onnx-1.16.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 cmake
+
+DESCRIPTION="Open Neural Network Exchange (ONNX)"
+HOMEPAGE="https://github.com/onnx/onnx"
+SRC_URI="https://github.com/onnx/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="disableStaticReg"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ dev-libs/protobuf:=
+ dev-cpp/abseil-cpp:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-1.15.0-hidden.patch
+ cmake_src_prepare
+ distutils-r1_src_prepare
+}
+
+python_configure_all()
+{
+ mycmakeargs=(
+ -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
+ -DONNX_USE_LITE_PROTO=ON
+ -DONNX_BUILD_SHARED_LIBS=ON
+ -DONNX_DISABLE_STATIC_REGISTRATION=$(usex disableStaticReg ON OFF)
+ )
+ cmake_src_configure
+}
+
+src_configure() {
+ distutils-r1_src_configure
+}
+
+src_compile() {
+ mycmakeargs=(
+ -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
+ -DONNX_USE_LITE_PROTO=ON
+ -DONNX_BUILD_SHARED_LIBS=ON
+ -DONNX_DISABLE_STATIC_REGISTRATION=$(usex disableStaticReg ON OFF)
+ )
+ CMAKE_ARGS="${mycmakeargs[@]}" distutils-r1_src_compile
+}
+
+python_compile_all() {
+ cmake_src_compile
+}
+
+python_install_all() {
+ cmake_src_install
+ distutils-r1_python_install_all
+}
+
+src_install() {
+ distutils-r1_src_install
+}