summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-13 00:45:25 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-13 01:40:24 +0200
commit292ba8f849c4bfff03e68225287e22cea8f621a5 (patch)
tree944537e8e74a692ed55f863dbd4eda41553ea645 /sci-mathematics/cryptominisat
parentsci-mathematics/cryptominisat: drop old 5.11.15 (diff)
downloadgentoo-292ba8f849c4bfff03e68225287e22cea8f621a5.tar.gz
gentoo-292ba8f849c4bfff03e68225287e22cea8f621a5.tar.bz2
gentoo-292ba8f849c4bfff03e68225287e22cea8f621a5.zip
sci-mathematics/cryptominisat: patch unistd include
Closes: https://bugs.gentoo.org/895118 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/cryptominisat')
-rw-r--r--sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild4
-rw-r--r--sci-mathematics/cryptominisat/files/cryptominisat-5.11.21-unistd.patch12
2 files changed, 16 insertions, 0 deletions
diff --git a/sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild b/sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild
index 4beb16299f8c..7de12b4067d1 100644
--- a/sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild
+++ b/sci-mathematics/cryptominisat/cryptominisat-5.11.21.ebuild
@@ -31,6 +31,10 @@ DEPEND="
${RDEPEND}
"
+PATCHES=(
+ "${FILESDIR}/${PN}-5.11.21-unistd.patch"
+)
+
src_configure() {
local -a mycmakeargs=(
-DNOBREAKID=ON
diff --git a/sci-mathematics/cryptominisat/files/cryptominisat-5.11.21-unistd.patch b/sci-mathematics/cryptominisat/files/cryptominisat-5.11.21-unistd.patch
new file mode 100644
index 000000000000..c64228a17862
--- /dev/null
+++ b/sci-mathematics/cryptominisat/files/cryptominisat-5.11.21-unistd.patch
@@ -0,0 +1,12 @@
+index f0a9e33..85286be 100644
+--- a/src/picosat/picosat.c
++++ b/src/picosat/picosat.c
+@@ -8148,7 +8148,7 @@ picosat_stats (PS * ps)
+ #else
+ #include <sys/time.h>
+ #include <sys/resource.h>
+-#include <sys/unistd.h>
++#include <unistd.h>
+ #endif
+
+ double