summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-07-26 08:44:09 +0200
committerTupone Alfredo <tupone@gentoo.org>2019-07-26 08:45:22 +0200
commit1080ec3defe35b1161935994afc48310b1f1ec27 (patch)
treefb81bf1a7bc45b412c919999759be83d389c0201 /sci-mathematics/psmt2-frontend
parentapp-misc/mc: drop slash stripping in ${ED} (diff)
downloadgentoo-1080ec3defe35b1161935994afc48310b1f1ec27.tar.gz
gentoo-1080ec3defe35b1161935994afc48310b1f1ec27.tar.bz2
gentoo-1080ec3defe35b1161935994afc48310b1f1ec27.zip
sci-mathematics/psmt2-frontend: add psmt2-frontend
Signed-off-by: Alfredo Tupone <tupone@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'sci-mathematics/psmt2-frontend')
-rw-r--r--sci-mathematics/psmt2-frontend/Manifest1
-rw-r--r--sci-mathematics/psmt2-frontend/files/psmt2-frontend-0.2-gentoo.patch22
-rw-r--r--sci-mathematics/psmt2-frontend/metadata.xml12
-rw-r--r--sci-mathematics/psmt2-frontend/psmt2-frontend-0.2.ebuild25
4 files changed, 60 insertions, 0 deletions
diff --git a/sci-mathematics/psmt2-frontend/Manifest b/sci-mathematics/psmt2-frontend/Manifest
new file mode 100644
index 000000000000..c13d8559bb56
--- /dev/null
+++ b/sci-mathematics/psmt2-frontend/Manifest
@@ -0,0 +1 @@
+DIST psmt2-frontend-0.2.tar.gz 26976 BLAKE2B 2b45ceb8d824f5b11455ad0026064b6329b6c6e6173c091b36dc42e8c1dd36924d12d9296db3dcfe748a84fdc37a1a530f3ef485bec904c19a0e6aa8034149f9 SHA512 c29802f4265a1cbdb05ee9154ce2c156136af258bc7283dd0fb1d1b2ce162b671553cab96484036d898e3ff7c26ab133f5c2e1ca88e9e48660b2faa139fd1f41
diff --git a/sci-mathematics/psmt2-frontend/files/psmt2-frontend-0.2-gentoo.patch b/sci-mathematics/psmt2-frontend/files/psmt2-frontend-0.2-gentoo.patch
new file mode 100644
index 000000000000..74fbed08bf6b
--- /dev/null
+++ b/sci-mathematics/psmt2-frontend/files/psmt2-frontend-0.2-gentoo.patch
@@ -0,0 +1,22 @@
+--- a/Makefile.in 2019-07-20 19:20:06.818740706 +0200
++++ b/Makefile.in 2019-07-20 19:21:33.437581073 +0200
+@@ -18,7 +18,7 @@
+ libdir=@libdir@
+ # exec_prefix=@exec_prefix@
+ # BINDIR=$(DESTDIR)@bindir@
+-LIBDIR=$(prefix)$(libdir)
++LIBDIR=$(libdir)
+ # DATADIR=$(DESTDIR)@datadir@/psmt2-frontend
+
+ # where to install the man page
+@@ -119,8 +119,8 @@
+ ##############
+
+ install: all META
+- mkdir -p $(DESTDIR)$(LIBDIR)
+- OCAMLFIND_DESTDIR=$(DESTDIR)$(LIBDIR) \
++ mkdir -p $(DESTDIR)$(OCAMLLIB)
++ OCAMLFIND_DESTDIR=$(DESTDIR)$(OCAMLLIB) \
+ ocamlfind install psmt2-frontend src/$(LIBNAME).* src/*.mli META
+
+
diff --git a/sci-mathematics/psmt2-frontend/metadata.xml b/sci-mathematics/psmt2-frontend/metadata.xml
new file mode 100644
index 000000000000..53441a5497e7
--- /dev/null
+++ b/sci-mathematics/psmt2-frontend/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ A library to parse and type-check a conservative extension of the
+ SMT-LIB 2 standard with prenex polymorphism.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/psmt2-frontend/psmt2-frontend-0.2.ebuild b/sci-mathematics/psmt2-frontend/psmt2-frontend-0.2.ebuild
new file mode 100644
index 000000000000..4e0ada140fe7
--- /dev/null
+++ b/sci-mathematics/psmt2-frontend/psmt2-frontend-0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit findlib autotools
+
+DESCRIPTION="Library to parse and type-check an extension of the SMT-LIB 2 standard"
+HOMEPAGE="https://github.com/OCamlPro-Coquera/psmt2-frontend"
+SRC_URI="https://github.com/OCamlPro-Coquera/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-ml/menhir-20181006"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}