summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2024-08-22 10:31:10 +1200
committerMichael Orlitzky <mjo@gentoo.org>2024-08-23 13:21:27 -0400
commit9616bb1a98f4695f0270bc0d025d66d9385c9f85 (patch)
treed90652ac030fa5e16decd6243c4c4553a4463e15 /sci-mathematics/singular
parentdev-python/pytest-asyncio: Bump to 0.24.0 (diff)
downloadgentoo-9616bb1a98f4695f0270bc0d025d66d9385c9f85.tar.gz
gentoo-9616bb1a98f4695f0270bc0d025d66d9385c9f85.tar.bz2
gentoo-9616bb1a98f4695f0270bc0d025d66d9385c9f85.zip
sci-mathematics/singular: add 4.4.0_p2
Closes: https://github.com/gentoo/gentoo/pull/38240 Signed-off-by: François Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/singular')
-rw-r--r--sci-mathematics/singular/Manifest1
-rw-r--r--sci-mathematics/singular/singular-4.4.0_p2.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/sci-mathematics/singular/Manifest b/sci-mathematics/singular/Manifest
index 47b4b29f7af8..8a392ba16a04 100644
--- a/sci-mathematics/singular/Manifest
+++ b/sci-mathematics/singular/Manifest
@@ -1 +1,2 @@
DIST singular-4.3.2p16.tar.gz 20880476 BLAKE2B ce226a6867b764e593ddbf2c71220d9ea14ccdfd956046d5a94dfb768a97927ca3cf961a9ea808cb77028f2c65d989032202d3a0bde555ace945df1e987077a8 SHA512 1dae0e229e124db03e5e240c3ab2f1049c9f77cf369f701c4a2d0767ba9c23baab2d5d14271e415a3ccbf7b9a9297fcf324b8ccc2841a5156d6ee846cb409de2
+DIST singular-4.4.0p2.tar.gz 20924020 BLAKE2B 0d663b830c37c96635303faeb14a55e0eff05bc378a3263cf83374893056b1c3175718f6b0870ac0c906a92eda59db0ca91a39a7b69a88d298a4a7993b9249d1 SHA512 df3faf025f30ab1c60460f661c4cec945a410311ca89d0756eafb57b430bb53ecec103b90ca91891fc7b1e720938a8259a9b256b6acd322c021c33e628b6654b
diff --git a/sci-mathematics/singular/singular-4.4.0_p2.ebuild b/sci-mathematics/singular/singular-4.4.0_p2.ebuild
new file mode 100644
index 000000000000..7cadc4a9aeac
--- /dev/null
+++ b/sci-mathematics/singular/singular-4.4.0_p2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common
+
+MY_PN=Singular
+MY_PV=$(ver_rs 3 '')
+# Consistency is different...
+MY_DIR2=$(ver_cut 1-3 ${PV})
+MY_DIR=$(ver_rs 1- '-' ${MY_DIR2})
+
+DESCRIPTION="Computer algebra system for polynomial computations"
+HOMEPAGE="https://www.singular.uni-kl.de/ https://github.com/Singular/Singular"
+SRC_URI="https://www.singular.uni-kl.de/ftp/pub/Math/${MY_PN}/SOURCES/${MY_DIR}/${PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_DIR2}"
+
+# Most files say "version 2 or version 3 of the License," which is not
+# quite GPL-2+, and is why we have listed GPL-2 below. But AFAIK there
+# are no GPL-2-only files.
+LICENSE="BSD GPL-2 GPL-2+ GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86 ~x86-linux"
+IUSE="emacs examples polymake +readline"
+
+# The interactive help uses "info" from sys-apps/texinfo.
+RDEPEND="
+ dev-lang/perl
+ dev-libs/gmp:0=
+ dev-libs/ntl:=
+ sci-libs/cddlib
+ sci-mathematics/flint:=
+ sys-apps/texinfo
+ emacs? ( app-editors/emacs:* )
+ polymake? ( sci-mathematics/polymake )
+ readline? ( sys-libs/readline:= )
+"
+DEPEND="${RDEPEND}"
+
+SITEFILE=60${PN}-gentoo.el
+
+src_configure() {
+ local myconf=(
+ --disable-debug
+ --disable-doc
+ --disable-optimizationflags
+ --disable-pyobject-module
+ --disable-python
+ --disable-python-module
+ --disable-python_module
+ --enable-factory
+ --enable-gfanlib
+ --enable-libfac
+ --with-flint
+ --with-gmp
+ --with-libparse
+ --with-ntl
+ --without-python
+ --without-pythonmodule
+ $(use_enable emacs)
+ $(use_enable polymake polymake-module)
+ $(use_with readline)
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ pushd "${S}"/emacs
+ elisp-compile *.el || die "elisp-compile failed"
+ popd
+ fi
+}
+
+src_install() {
+ # Do not compress singular's info file (singular.hlp)
+ # some consumer of that file do not know how to deal with compression
+ docompress -x /usr/share/info
+
+ default
+
+ dosym Singular /usr/bin/"${PN}"
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+src_test() {
+ # SINGULAR_PROCS_DIR need to be set to "" otherwise plugins from
+ # an already installed version of singular may be used and cause segfault
+ # See https://github.com/Singular/Sources/issues/980
+ SINGULAR_PROCS_DIR="" emake check
+}
+
+pkg_postinst() {
+ einfo "Additional functionality can be enabled by installing"
+ einfo "sci-mathematics/4ti2"
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}