summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-08 10:44:55 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-08 10:56:16 +0200
commit8c4b9659dd3ae5ff78f6c74d2ef92005d8b71a6c (patch)
tree77226ce67658d352a8fee99a218c921f0000b0d8 /sci-mathematics/z3
parentnet-libs/libssh2: Port to cmake.eclass (diff)
downloadgentoo-8c4b9659dd3ae5ff78f6c74d2ef92005d8b71a6c.tar.gz
gentoo-8c4b9659dd3ae5ff78f6c74d2ef92005d8b71a6c.tar.bz2
gentoo-8c4b9659dd3ae5ff78f6c74d2ef92005d8b71a6c.zip
sci-mathematics/z3: Port to cmake.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-mathematics/z3')
-rw-r--r--sci-mathematics/z3/z3-4.8.8.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sci-mathematics/z3/z3-4.8.8.ebuild b/sci-mathematics/z3/z3-4.8.8.ebuild
index 949c33e2e2b1..c6b4ae89c61e 100644
--- a/sci-mathematics/z3/z3-4.8.8.ebuild
+++ b/sci-mathematics/z3/z3-4.8.8.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{6,7,8} )
inherit cmake-multilib python-single-r1 toolchain-funcs
@@ -39,11 +40,11 @@ multilib_src_configure() {
-DZ3_INCLUDE_GIT_HASH=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_test() {
- cmake-utils_src_make test-z3
+ cmake_build test-z3
set -- "${BUILD_DIR}"/test-z3 /a
echo "${@}" >&2
"${@}" || die