summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-05-21 18:45:43 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-05-21 21:39:23 -0400
commit82385f2e4c92e90ec78581d80a91d2f5c2659e99 (patch)
treed6950e087dabcfd4decc6c6419040bb15de804ac /sci-mathematics
parentsci-mathematics/polymake: add 4.9, drop 4.8 (diff)
downloadgentoo-82385f2e4c92e90ec78581d80a91d2f5c2659e99.tar.gz
gentoo-82385f2e4c92e90ec78581d80a91d2f5c2659e99.tar.bz2
gentoo-82385f2e4c92e90ec78581d80a91d2f5c2659e99.zip
sci-mathematics/normaliz: add 3.10.0
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/normaliz/Manifest1
-rw-r--r--sci-mathematics/normaliz/normaliz-3.10.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/sci-mathematics/normaliz/Manifest b/sci-mathematics/normaliz/Manifest
index dca93e793264..29d799e77b20 100644
--- a/sci-mathematics/normaliz/Manifest
+++ b/sci-mathematics/normaliz/Manifest
@@ -1 +1,2 @@
+DIST normaliz-3.10.0.tar.gz 5177794 BLAKE2B ef2ed089da0bf7b286f477837d8793466c1b030ea0f321cd74e910461a6bd28705f971d1b987ef59aa783311dc247e2838d5acf850cb1948e429c98e1ca440f0 SHA512 febc43f846607dcfca8bcf462e8ccf655e2e6e10dcb2741412c08489fc9b2e99410306dc4b078084bfe73e41113849b201e6f7f5a8e2ae07508ebf1c043f95a3
DIST normaliz-3.9.3.tar.gz 4946498 BLAKE2B 3faff64fda86216ee11b0f55ba1341d70988472f65eedafe5b52bf6b05abd817add2dbab45144de0a43d02c501caf3c4a89d66c2b2d621b81188a2a5100d158f SHA512 5d6866cc35835c196d22d6b4b0d5f0e3e2e00f772553115fbbabd8415b20388cf367cf9a282904a72c03c2ef482b804f7009d67e3334add4fc37f3bab675da6c
diff --git a/sci-mathematics/normaliz/normaliz-3.10.0.ebuild b/sci-mathematics/normaliz/normaliz-3.10.0.ebuild
new file mode 100644
index 000000000000..055e1f8973ca
--- /dev/null
+++ b/sci-mathematics/normaliz/normaliz-3.10.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Tool for computations in affine monoids and more"
+HOMEPAGE="https://www.normaliz.uni-osnabrueck.de/"
+SRC_URI="https://github.com/Normaliz/Normaliz/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc extras nauty openmp"
+
+RDEPEND="
+ dev-libs/gmp:=[cxx(+)]
+ nauty? ( sci-mathematics/nauty )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+"
+# Only a boost header is needed -> not RDEPEND
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ # Fix C standard compliance.
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # flint (and arb, which doesn't make an appearance in ./configure --help)
+ # is somehow connected to e-antic, which we do not yet package. Likewise
+ # we have no packages for cocoalib or hashlibrary.
+ econf \
+ $(use_enable openmp) \
+ $(use_with nauty) \
+ --without-cocoalib \
+ --without-hashlibrary \
+ --without-flint \
+ --without-e-antic \
+ --disable-static
+}
+
+src_compile() {
+ # Clobber the default "AM_LDFLAGS = -Wl,-s" to avoid QA warnings
+ # about pre-stripped binaries.
+ emake AM_LDFLAGS=""
+}
+
+src_install() {
+ default
+
+ use doc && dodoc doc/Normaliz.pdf doc/NmzShortRef.pdf
+ if use extras; then
+ newdoc Singular/normaliz.pdf singular-normaliz.pdf
+ insinto /usr/share/${PN}
+ doins Singular/normaliz.lib
+ doins Macaulay2/Normaliz.m2
+ fi
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}