summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-08 15:55:52 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-08 15:57:54 +0200
commitc682943c6c484f0cef936ab834da1b89df85cbad (patch)
treebb02e164cd8eb32e24c6f08f7f33ab7d4ebbb834 /sci-mathematics
parentdev-cpp/abseil-cpp: Stabilize 20240116.2-r4 ppc64, #938835 (diff)
downloadgentoo-c682943c6c484f0cef936ab834da1b89df85cbad.tar.gz
gentoo-c682943c6c484f0cef936ab834da1b89df85cbad.tar.bz2
gentoo-c682943c6c484f0cef936ab834da1b89df85cbad.zip
sci-mathematics/dunshire: Remove `det setup.py` false positive
Remove the pointless call to `distutils_enable_tests setup.py` that is a false positive on packages broken by new dev-python/setuptools versions. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild b/sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild
index c98c5b6bf51d..348bf1942132 100644
--- a/sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild
+++ b/sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild
@@ -5,26 +5,32 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
+
inherit distutils-r1
DESCRIPTION="Python library to solve linear games over symmetric cones"
HOMEPAGE="https://michael.orlitzky.com/code/dunshire/"
SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
LICENSE="AGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/cvxopt[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
-RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
DOCS=( doc/README.rst )
distutils_enable_sphinx doc/source
-# There are no additional dependencies even though we're not really
-# using setup.py to run the test suite any more. The __main__.py
-# runner has its own exit code handling.
-distutils_enable_tests setup.py
-
python_test() {
PYTHONPATH="." "${EPYTHON}" test/__main__.py --verbose || die
}