summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-07-13 16:07:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-07-13 16:24:17 +0200
commitbea15aae800b07ee8b5e37eed9c3ca37573d5ce1 (patch)
tree0439aaa8b68d68b9e36f51758891c5a8d4f21eb1 /sci-visualization
parentdev-libs/libclc: Add 19.0.0_pre20240712 snapshot (diff)
downloadgentoo-bea15aae800b07ee8b5e37eed9c3ca37573d5ce1.tar.gz
gentoo-bea15aae800b07ee8b5e37eed9c3ca37573d5ce1.tar.bz2
gentoo-bea15aae800b07ee8b5e37eed9c3ca37573d5ce1.zip
sci-visualization/labplot: Port to KF6, update dependencies and IUSE
Upstream commits: b4c72d6ea542c82720c5730663a62b530a435b63 a29eee61e3fbd67154e94eaaa1e0050e87a7b50b 0c49873bcbd10471cc6df2dc875027ed53b11d42 5e21792e0e0f506c89f3b160606484e96f67207b d1ef379f64887b5ad9376750ba552805d998e95c a187e0e03a5bfdea38b15cceda906b0a47073d08 8084df037928690755dcc72c536270022f8c4d1f 8330bccae191f3e25a8fa20a93fc193a0578e887 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/labplot/labplot-9999.ebuild89
-rw-r--r--sci-visualization/labplot/metadata.xml3
2 files changed, 54 insertions, 38 deletions
diff --git a/sci-visualization/labplot/labplot-9999.ebuild b/sci-visualization/labplot/labplot-9999.ebuild
index dceb294dff35..f83aea5d78d6 100644
--- a/sci-visualization/labplot/labplot-9999.ebuild
+++ b/sci-visualization/labplot/labplot-9999.ebuild
@@ -5,9 +5,8 @@ EAPI=8
ECM_HANDBOOK="forceoptional"
ECM_TEST="forceoptional"
-KFMIN=5.88.0
-QTMIN=5.15.2
-VIRTUALX_REQUIRED="test"
+KFMIN=6.3.0
+QTMIN=6.6.2
inherit ecm kde.org
DESCRIPTION="Scientific data analysis and visualisation based on KDE Frameworks"
@@ -18,38 +17,35 @@ if [[ ${KDE_BUILD_TYPE} = release ]]; then
fi
LICENSE="GPL-2"
-SLOT="5"
-IUSE="cantor excel fftw fits hdf5 libcerf markdown matio netcdf origin root serial telemetry"
+SLOT="0"
+IUSE="eigen excel fftw fits hdf5 libcerf markdown matio netcdf ods origin root serial share telemetry"
+# IUSE="cantor"
+# cantor? (
+# >=kde-apps/cantor-19.12.0:6
+# >=kde-frameworks/kparts-${KFMIN}:6
+# >=kde-frameworks/kservice-${KFMIN}:6
+# )
DEPEND="
- app-text/poppler
- >=dev-qt/qtconcurrent-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtnetwork-${QTMIN}:5
- >=dev-qt/qtprintsupport-${QTMIN}:5
- >=dev-qt/qtsql-${QTMIN}:5
- >=dev-qt/qtsvg-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=kde-frameworks/karchive-${KFMIN}:5
- >=kde-frameworks/kcompletion-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kiconthemes-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/knewstuff-${KFMIN}:5
- >=kde-frameworks/kcrash-${KFMIN}:5
- >=kde-frameworks/ktextwidgets-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- >=kde-frameworks/syntax-highlighting-${KFMIN}:5
+ app-text/poppler[qt6(-)]
+ >=dev-qt/qtbase-${QTMIN}:6=[concurrent,gui,network,sql,widgets]
+ >=dev-qt/qtsvg-${QTMIN}:6
+ >=kde-frameworks/karchive-${KFMIN}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/knewstuff-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ >=kde-frameworks/syntax-highlighting-${KFMIN}:6
>=sci-libs/gsl-1.15:=
- cantor? (
- >=kde-apps/cantor-19.12.0:5
- >=kde-frameworks/kparts-${KFMIN}:5
- >=kde-frameworks/kservice-${KFMIN}:5
- )
+ eigen? ( dev-cpp/eigen:3= )
excel? ( dev-libs/qxlsx:= )
fftw? ( sci-libs/fftw:3.0= )
fits? ( sci-libs/cfitsio:= )
@@ -58,28 +54,43 @@ DEPEND="
markdown? ( app-text/discount:= )
matio? ( sci-libs/matio:= )
netcdf? ( sci-libs/netcdf:= )
+ ods? (
+ dev-libs/libixion:=
+ dev-libs/liborcus:=
+ )
origin? ( sci-libs/liborigin:2 )
root? (
app-arch/lz4
sys-libs/zlib
)
- serial? ( >=dev-qt/qtserialport-${QTMIN}:5 )
- telemetry? ( kde-frameworks/kuserfeedback:5 )
+ serial? ( >=dev-qt/qtserialport-${QTMIN}:6 )
+ share? ( >=kde-frameworks/purpose-${KFMIN}:6 )
+ telemetry? ( >=kde-frameworks/kuserfeedback-${KFMIN}:6 )
+"
+RDEPEND="${DEPEND}
+ !${CATEGORY}/${PN}:5
"
-RDEPEND="${DEPEND}"
# not packaged: dev-qt/qtmqtt, bug 683994
BDEPEND="
app-alternatives/yacc
sys-devel/gettext
"
+src_prepare() {
+ ecm_src_prepare
+
+ sed -e "/^ *find_package.*QT NAMES/s/Qt5 //" \
+ -i CMakeLists.txt || die # ensure Qt6 build
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_MQTT=OFF # not packaged
-DENABLE_READSTAT=OFF # not packaged
-DENABLE_VECTOR_BLF=OFF # not packaged
- -DENABLE_CANTOR=$(usex cantor)
- -DENABLE_EXCEL=$(usex excel)
+ -DENABLE_CANTOR=OFF # $(usex cantor)
+ -DENABLE_EIGEN3=$(usex eigen)
+ -DENABLE_XLSX=$(usex excel)
-DENABLE_FFTW=$(usex fftw)
-DENABLE_FITS=$(usex fits)
-DENABLE_HDF5=$(usex hdf5)
@@ -87,10 +98,12 @@ src_configure() {
-DENABLE_DISCOUNT=$(usex markdown)
-DENABLE_MATIO=$(usex matio)
-DENABLE_NETCDF=$(usex netcdf)
+ -DENABLE_ORCUS=$(usex ods)
-DENABLE_LIBORIGIN=$(usex origin)
+ $(cmake_use_find_package share KF6Purpose)
-DENABLE_ROOT=$(usex root)
-DENABLE_QTSERIALPORT=$(usex serial)
- $(cmake_use_find_package telemetry KUserFeedback)
+ $(cmake_use_find_package telemetry KUserFeedbackQt6) # FIXME: should be KF6UserFeedback
-DENABLE_TESTS=$(usex test)
)
diff --git a/sci-visualization/labplot/metadata.xml b/sci-visualization/labplot/metadata.xml
index 96a92087bc72..f535220dfd09 100644
--- a/sci-visualization/labplot/metadata.xml
+++ b/sci-visualization/labplot/metadata.xml
@@ -18,13 +18,16 @@
</upstream>
<use>
<flag name="cantor">Enable support for different open-source computer algebra systems via <pkg>kde-apps/cantor</pkg></flag>
+ <flag name="eigen">Enable support for fast baseline removal via <pkg>dev-cpp/eigen</pkg></flag>
<flag name="excel">Enable support for importing/exporting Microsoft Excel files (.xlsx) via <pkg>dev-libs/qxlsx</pkg></flag>
<flag name="fits">Enable support for NASA's <pkg>sci-libs/cfitsio</pkg> library</flag>
<flag name="libcerf">Enable special functions from <pkg>sci-libs/libcerf</pkg></flag>
<flag name="markdown">Enable Markdown support via <pkg>app-text/discount</pkg></flag>
<flag name="matio">Enable support for matio (<pkg>sci-libs/matio</pkg>)</flag>
+ <flag name="ods">Enable support for importing/exporting OpenDocument spreadsheets (.ods) via <pkg>dev-libs/liborcus</pkg></flag>
<flag name="origin">Enable support for reading OriginLab OPJ project files through <pkg>sci-libs/liborigin</pkg></flag>
<flag name="root">Enable support for CERN's ROOT file type</flag>
<flag name="serial">Enable support for RS232 serial ports using <pkg>dev-qt/qtserialport</pkg></flag>
+ <flag name="share">Enable support for a share menu using <pkg>kde-frameworks/purpose</pkg></flag>
</use>
</pkgmetadata>