summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHank Leininger <hlein@korelogic.com>2024-02-08 15:40:08 -0700
committerJoonas Niilola <juippis@gentoo.org>2024-03-04 09:53:47 +0200
commitcfa15707466135b28ce5dc8ba871b9c69ec4d716 (patch)
tree538d4650d1139a43f531cc3247525b9c82c319b6 /sec-keys/openpgp-keys-fwknop/openpgp-keys-fwknop-20240208.ebuild
parentnet-misc/openvswitch: add 2.17.8 (diff)
downloadgentoo-cfa15707466135b28ce5dc8ba871b9c69ec4d716.tar.gz
gentoo-cfa15707466135b28ce5dc8ba871b9c69ec4d716.tar.bz2
gentoo-cfa15707466135b28ce5dc8ba871b9c69ec4d716.zip
sec-keys/openpgp-keys-fwknop: new package, add 20240208
Signed-off-by: Hank Leininger <hlein@korelogic.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sec-keys/openpgp-keys-fwknop/openpgp-keys-fwknop-20240208.ebuild')
-rw-r--r--sec-keys/openpgp-keys-fwknop/openpgp-keys-fwknop-20240208.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-fwknop/openpgp-keys-fwknop-20240208.ebuild b/sec-keys/openpgp-keys-fwknop/openpgp-keys-fwknop-20240208.ebuild
new file mode 100644
index 000000000000..3eaf5e975b68
--- /dev/null
+++ b/sec-keys/openpgp-keys-fwknop/openpgp-keys-fwknop-20240208.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="OpenPGP key used to sign fwknop releases"
+HOMEPAGE="https://www.cipherdyne.org/fwknop/index.html"
+SRC_URI="https://www.cipherdyne.org/signing_key -> ${P}.asc"
+S="${WORKDIR}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+src_install() {
+ local files=( ${A} )
+ insinto /usr/share/openpgp-keys
+ newins - fwknop.gpg < <(cat "${files[@]/#/${DISTDIR}/}")
+}