summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-02 16:45:10 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-02 17:15:01 +0100
commit3d5103d43025604f8202693e24ad3c94295886ef (patch)
tree567e286f56f0c2ebebe0278367ba89ee731cab76 /sys-apps/bar
parentsys-apps/audio-entropyd: Port to EAPI 6 (diff)
downloadgentoo-3d5103d43025604f8202693e24ad3c94295886ef.tar.gz
gentoo-3d5103d43025604f8202693e24ad3c94295886ef.tar.bz2
gentoo-3d5103d43025604f8202693e24ad3c94295886ef.zip
sys-apps/bar: Port to EAPI 6
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'sys-apps/bar')
-rw-r--r--sys-apps/bar/Manifest2
-rw-r--r--sys-apps/bar/bar-1.11.1.ebuild27
2 files changed, 14 insertions, 15 deletions
diff --git a/sys-apps/bar/Manifest b/sys-apps/bar/Manifest
index 967642185f7a..edf1c0e40d4e 100644
--- a/sys-apps/bar/Manifest
+++ b/sys-apps/bar/Manifest
@@ -1 +1 @@
-DIST bar_1.11.1.tar.gz 187144 SHA256 fa0f5ec5c8400316c2f4debdc6cdcb80e186e668c2e4471df4fec7bfcd626503 SHA512 18a0cf1946155252fc84bce64a1789a2a497c8a870a8494e4b2caecde567121dc6404855c021900358659702a33f8c4f749e9cd0bb1eb761cd650e2c56347035 WHIRLPOOL b5e144841d92af9f23cc66ba81ad921a81729d58189ef8e82694b124e9f77fb36dc2f8f379a957c699b09ed405b5cf9891adb50f89a62e1ce2477ce48fe3ae5c
+DIST bar_1.11.1.tar.gz 187144 BLAKE2B 9181ade20a9450bdc7c4ae21bb79fea1d8666ebb78c1ae6403bbc1ad46ec968efb3795da3d5cd2e87aa02d28f33105abb3cf629e04051b84e763ddaea9c9ee18 SHA512 18a0cf1946155252fc84bce64a1789a2a497c8a870a8494e4b2caecde567121dc6404855c021900358659702a33f8c4f749e9cd0bb1eb761cd650e2c56347035
diff --git a/sys-apps/bar/bar-1.11.1.ebuild b/sys-apps/bar/bar-1.11.1.ebuild
index ff678910027e..0d1aadd2a030 100644
--- a/sys-apps/bar/bar-1.11.1.ebuild
+++ b/sys-apps/bar/bar-1.11.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
inherit autotools
@@ -18,31 +18,30 @@ DEPEND="doc? ( >=app-doc/doxygen-1.3.5 )"
RDEPEND=""
src_prepare() {
- sed -e '/^LDFLAGS/d' \
- -e '/cd $(WEB_DIR) && $(MAKE)/d' -i Makefile.am || die
+ default
+ sed '/cd $(WEB_DIR) && $(MAKE)/d' -i Makefile.am || die
eautomake
}
src_configure() {
- local myconf
-
- # Fix wrt #113392
- use sparc && myconf="${myconf} --disable-use-memalign"
- econf ${myconf}
+ # Fix bug 113392
+ econf $(use_enable !sparc use-memalign)
}
src_compile() {
emake CFLAGS="${CFLAGS}"
+
if use doc; then
- mkdir -p ../www/doxygen/${PV}
+ mkdir -p ../www/doxygen/${PV} || die
emake update-www
+ HTML_DOCS=( ../www/doxygen/${PV}/html/. )
+
+ # remove doxygen working files
+ find ../www/doxygen/${PV}/html \( -iname '*.map' -o -iname '*.md5' \) -delete || die
fi
}
src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS TODO TROUBLESHOOTING debian/changelog
- if use doc ; then
- dohtml -r ../www/doxygen/${PV}/html/*
- fi
+ default
+ dodoc TROUBLESHOOTING debian/changelog
}