summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-10-02 01:17:56 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-10-02 01:17:56 +0200
commitd60a00610dcab44f9ba2d3f80badb07c173a761a (patch)
tree0b9c1b70efb0008e56d8fa0feba3b1f44534bf56 /sys-apps/cpuid/cpuid-20220927.ebuild
parentdev-libs/intel-vc-intrinsics: add 0.7.1 (diff)
downloadgentoo-d60a00610dcab44f9ba2d3f80badb07c173a761a.tar.gz
gentoo-d60a00610dcab44f9ba2d3f80badb07c173a761a.tar.bz2
gentoo-d60a00610dcab44f9ba2d3f80badb07c173a761a.zip
sys-apps/cpuid: add 20220927
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/cpuid/cpuid-20220927.ebuild')
-rw-r--r--sys-apps/cpuid/cpuid-20220927.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/cpuid/cpuid-20220927.ebuild b/sys-apps/cpuid/cpuid-20220927.ebuild
new file mode 100644
index 000000000000..0f77190b474c
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20220927.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+BDEPEND="
+ app-arch/gzip
+ dev-lang/perl
+"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20220620-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}