summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2024-10-21 02:43:19 +0200
committerSebastian Pipping <sping@gentoo.org>2024-10-21 02:43:19 +0200
commit2d9d9245cafbbc8ff381f4c0c6509fa8f4c91af9 (patch)
tree5788053e9fd53d76fed94d24b7221a6810f6f5d1 /sys-apps/dcfldd
parentsys-apps/dcfldd: Drop old (diff)
downloadgentoo-2d9d9245cafbbc8ff381f4c0c6509fa8f4c91af9.tar.gz
gentoo-2d9d9245cafbbc8ff381f4c0c6509fa8f4c91af9.tar.bz2
gentoo-2d9d9245cafbbc8ff381f4c0c6509fa8f4c91af9.zip
sys-apps/dcfldd: 1.9.2 with musl libc support
Closes: https://bugs.gentoo.org/713646 Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'sys-apps/dcfldd')
-rw-r--r--sys-apps/dcfldd/Manifest1
-rw-r--r--sys-apps/dcfldd/dcfldd-1.9.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/dcfldd/Manifest b/sys-apps/dcfldd/Manifest
index f012770b8a6e..c399985f54c3 100644
--- a/sys-apps/dcfldd/Manifest
+++ b/sys-apps/dcfldd/Manifest
@@ -1 +1,2 @@
DIST dcfldd-1.9.1.tar.gz 90536 BLAKE2B 644a96ba193ab0275a805c5bad1bc64fcfc2386c2aace4be1d523d6adb52ded6dc02ec2b0c40f1427772e00f6bef285f0fa515e99fa1793a0e1341916a41bd3a SHA512 bef5dfaa25a51889efcadec101948c4d0e3cbf6ee4a624e4818502bbc78b458310f7b67538946dff927713b7ce6294d269dd3ddba0685fb367988eec582d1f02
+DIST dcfldd-1.9.2.tar.gz 92556 BLAKE2B 8d5e5d5698ce4818d00c035708904483190b5d0f4968d466a19e57053d659809519e9ae0f1d9e98f577799be61c73c6c16442b7c95405313bcd5c1587286a842 SHA512 860199fc9d295ae71c868db67825b58496fb60fe74d58b7827ec115e05463cd69e96b037e159ab5ff65ada3a6a46cc67dc8b2ea7811443d3dc45a95d1c674c7d
diff --git a/sys-apps/dcfldd/dcfldd-1.9.2.ebuild b/sys-apps/dcfldd/dcfldd-1.9.2.ebuild
new file mode 100644
index 000000000000..0a9834591b0d
--- /dev/null
+++ b/sys-apps/dcfldd/dcfldd-1.9.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools bash-completion-r1
+
+DESCRIPTION="enhanced dd with features for forensics and security"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/dcfldd"
+SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+
+DEPEND="virtual/pkgconfig"
+
+DOCS=(
+ AUTHORS
+ CONTRIBUTING.md
+ ChangeLog
+ NEWS
+ README.md
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-bash-completion
+}
+
+src_install() {
+ default
+
+ # Fix Bash completion filename
+ mv "${D}$(get_bashcompdir)"/dcfldd{-bash_completion,} || die
+}