summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-29 07:32:40 +0000
committerSam James <sam@gentoo.org>2023-01-29 07:33:13 +0000
commitcc023c47f0a30174d43fb940109fce5781edda95 (patch)
treecf262059e4ee4e6414eb689aca55c2e354ad4170 /sys-apps/diffutils
parentprofiles: mask =sys-fs/lvm2-2.03.18 (crashes) (diff)
downloadgentoo-cc023c47f0a30174d43fb940109fce5781edda95.tar.gz
gentoo-cc023c47f0a30174d43fb940109fce5781edda95.tar.bz2
gentoo-cc023c47f0a30174d43fb940109fce5781edda95.zip
sys-apps/diffutils: fix tests w/ make 4.4
Closes: https://bugs.gentoo.org/879891 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/diffutils')
-rw-r--r--sys-apps/diffutils/diffutils-3.9.ebuild10
-rw-r--r--sys-apps/diffutils/files/diffutils-3.9-make-4.4-test-color.patch30
2 files changed, 38 insertions, 2 deletions
diff --git a/sys-apps/diffutils/diffutils-3.9.ebuild b/sys-apps/diffutils/diffutils-3.9.ebuild
index ebbd0424d186..acce50bad293 100644
--- a/sys-apps/diffutils/diffutils-3.9.ebuild
+++ b/sys-apps/diffutils/diffutils-3.9.ebuild
@@ -27,8 +27,14 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="nls static"
-BDEPEND="nls? ( sys-devel/gettext )
- verify-sig? ( sec-keys/openpgp-keys-diffutils )"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ verify-sig? ( sec-keys/openpgp-keys-diffutils )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-make-4.4-test-color.patch
+)
src_configure() {
use static && append-ldflags -static
diff --git a/sys-apps/diffutils/files/diffutils-3.9-make-4.4-test-color.patch b/sys-apps/diffutils/files/diffutils-3.9-make-4.4-test-color.patch
new file mode 100644
index 000000000000..01f6aeedc956
--- /dev/null
+++ b/sys-apps/diffutils/files/diffutils-3.9-make-4.4-test-color.patch
@@ -0,0 +1,30 @@
+https://bugs.gentoo.org/879891
+https://debbugs.gnu.org/cgi/bugreport.cgi?bug=59905
+https://git.savannah.gnu.org/cgit/diffutils.git/commit/?id=89f3daeaaf021a77177daec8666bcd80ec476833
+
+From 89f3daeaaf021a77177daec8666bcd80ec476833 Mon Sep 17 00:00:00 2001
+From: Jim Meyering <meyering@fb.com>
+Date: Mon, 16 Jan 2023 15:48:10 -0800
+Subject: tests: accommodate newer GNU make's SIGPIPE-ignore
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+* tests/colors: Allow an exit code of not just 141 (SIGPIPE),
+but also "error": 2.
+Reported by Tomasz Kłoczko in http://bugs.gnu.org/59905.
+--- a/tests/colors
++++ b/tests/colors
+@@ -128,6 +128,9 @@ printf '%1000000s-a' > a
+ printf '%1000000s-b' > b
+ head -c 10 < fifo > /dev/null &
+ diff --color=always ---presume-output-tty a b > fifo
+-test $? = 141 || fail=1
++
++# Depending on version of GNU make (4.3.92-4.4 set SIGPIPE to "ignore"),
++# either of these is acceptable.
++case $? in 2|141) ;; *) fail=1 ;; esac
+
+ Exit $fail
+--
+cgit v1.1