summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-10-14 22:48:04 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-10-14 22:48:04 +0200
commitfb3e1aaf3d698ecc2f4130b5ce1862485c877bf7 (patch)
treeb9b7404096aac4a58fd858b15619e3d1b1500e26 /sys-apps/dmidecode/dmidecode-3.3.ebuild
parentdev-lang/spidermonkey: skip typedarray-arg-set-values-same-buffer-other-type.... (diff)
downloadgentoo-fb3e1aaf3d698ecc2f4130b5ce1862485c877bf7.tar.gz
gentoo-fb3e1aaf3d698ecc2f4130b5ce1862485c877bf7.tar.bz2
gentoo-fb3e1aaf3d698ecc2f4130b5ce1862485c877bf7.zip
sys-apps/dmidecode: Bump to version 3.3
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/dmidecode/dmidecode-3.3.ebuild')
-rw-r--r--sys-apps/dmidecode/dmidecode-3.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/dmidecode/dmidecode-3.3.ebuild b/sys-apps/dmidecode/dmidecode-3.3.ebuild
new file mode 100644
index 000000000000..8e6e738c4474
--- /dev/null
+++ b/sys-apps/dmidecode/dmidecode-3.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="DMI (Desktop Management Interface) table related utilities"
+HOMEPAGE="https://www.nongnu.org/dmidecode/"
+SRC_URI="https://savannah.nongnu.org/download/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-solaris"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-dmidecode )"
+DEPEND=""
+
+src_prepare() {
+ default
+ sed -i \
+ -e "/^prefix/s:/usr/local:${EPREFIX}/usr:" \
+ -e "/^docdir/s:dmidecode:${PF}:" \
+ -e '/^PROGRAMS !=/d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)"
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ einfo "dmidecode needs root privileges to read /dev/xsvc"
+ einfo "To make dmidecode useful, either run as root, or chown and setuid the binary."
+ einfo "Note that /usr/sbin/ptrconf and /usr/sbin/ptrdiag give similar"
+ einfo "information without requiring root privileges."
+ fi
+}