summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-20 11:53:10 +0000
committerSam James <sam@gentoo.org>2022-01-20 12:02:08 +0000
commit3eb4520c365bd11a227a3f56dfbfffa4c4bfb1c4 (patch)
tree3cfd9e900a58f18f09170cdbdf807b93d541f61e /sys-apps/ethtool
parentapp-text/lesspipe: drop 1.85, 1.89, 1.90, 2.00 (diff)
downloadgentoo-3eb4520c365bd11a227a3f56dfbfffa4c4bfb1c4.tar.gz
gentoo-3eb4520c365bd11a227a3f56dfbfffa4c4bfb1c4.tar.bz2
gentoo-3eb4520c365bd11a227a3f56dfbfffa4c4bfb1c4.zip
sys-apps/ethtool: add 5.16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/ethtool')
-rw-r--r--sys-apps/ethtool/Manifest1
-rw-r--r--sys-apps/ethtool/ethtool-5.16.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/sys-apps/ethtool/Manifest b/sys-apps/ethtool/Manifest
index 32c2530c2a69..02ad48503a32 100644
--- a/sys-apps/ethtool/Manifest
+++ b/sys-apps/ethtool/Manifest
@@ -1,3 +1,4 @@
DIST ethtool-5.10.tar.xz 310536 BLAKE2B acc91ff2f7cf233a5a7bc85e32fbcf78e3923b240ab3e3300fa11d42769b664b1b5740ad6577daf4ef1b1054432e2323429ee63774af5e0210c1ec1c7d6aa4ac SHA512 128ecc0445ec44e231d95158a71cea2c03f059314f1a844cfb2f424970bd68608fb73b8dc5e8905b88ad0da2b65a8884a626be78d6d25f770ce043c6c87580a6
DIST ethtool-5.14.tar.xz 318536 BLAKE2B 09b5c9c8103635e33b22e55caff3b0f3751bf14d48de63e025587814c6b0d7e80962cd8ed27b6be7ae35a5a9d5decd0a9127a69a7cbbd52e2218bb3fc9e9b176 SHA512 880c4b6d5f83c25cabc6101222a5abf5f7e5e6501165ba5cdb420da242c351d7c32c1cffacfa1bcf0c4655434d89c64d39f0809af0d38f626a0a78f92ec68f87
DIST ethtool-5.15.tar.xz 318864 BLAKE2B 855c07e388bfabf37637f20e2714c6ca27717f38d7f658be96e0e9ec9d4514e61f4ee29361fc0279510869606ad18126ccd2a47160f1097ab52b1e35216e9721 SHA512 28147468a92c179217b459907a3257ee4f2d2ed028cb87b074f1c7ca6eb91aca81c8a9f5c7fe74e81d16a516e6e7eb20137bf7a15b5479fd82a327c64954da12
+DIST ethtool-5.16.tar.xz 320308 BLAKE2B 198d76502510e533b7f51785fd9f0848e840a6b4237bfd0496d005978ce3e638be02bd7dee971501f57c83354a1ac2f34a7ef29f2255764e900d9299bad9254c SHA512 9f0c24323b3144cbc6e684dc8c545a7c5e4804a061f10e32c937ea7420cc25c0891137fd4be4f1b9cf44907d8a59970ead9db424051ec5b4a90c225038f04025
diff --git a/sys-apps/ethtool/ethtool-5.16.ebuild b/sys-apps/ethtool/ethtool-5.16.ebuild
new file mode 100644
index 000000000000..ac936a3334cd
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-5.16.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+netlink"
+
+BDEPEND="app-arch/xz-utils"
+RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable netlink)
+}