summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-21 16:29:20 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-21 16:29:32 -0400
commitc540f9ea27b6c6e14481b3364d6193862a3377b1 (patch)
treec82d8f86c49fbac157bfd4682235998b40dc076b /sys-apps/file/file-9999.ebuild
parentdev-games/aseprite: Grant maintainership to proxy maintainer. (diff)
downloadgentoo-c540f9ea27b6c6e14481b3364d6193862a3377b1.tar.gz
gentoo-c540f9ea27b6c6e14481b3364d6193862a3377b1.tar.bz2
gentoo-c540f9ea27b6c6e14481b3364d6193862a3377b1.zip
sys-apps/file: add a bunch of upstream fixes
Diffstat (limited to 'sys-apps/file/file-9999.ebuild')
-rw-r--r--sys-apps/file/file-9999.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sys-apps/file/file-9999.ebuild b/sys-apps/file/file-9999.ebuild
index 88b9d2e8c5d9..5aa9298bfd41 100644
--- a/sys-apps/file/file-9999.ebuild
+++ b/sys-apps/file/file-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
EAPI="5"
+
PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
DISTUTILS_OPTIONAL=1
@@ -25,9 +25,7 @@ SLOT="0"
IUSE="python static-libs zlib"
DEPEND="python? ( ${PYTHON_DEPS} )
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
- abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20131008-r21
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
RDEPEND="${DEPEND}
python? ( !dev-python/python-magic )"
@@ -80,7 +78,7 @@ multilib_src_compile() {
}
src_compile() {
- if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
+ if tc-is-cross-compiler && ! ROOT=/ has_version "~${CATEGORY}/${P}" ; then
emake -C "${WORKDIR}"/build/src file
PATH="${WORKDIR}/build/src:${PATH}"
fi