summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-08-09 05:52:18 -0500
committerBen Kohler <bkohler@gentoo.org>2022-08-09 05:54:51 -0500
commitc5cade04db2e914a4a29c219743fd601c914fc2b (patch)
tree0c3b064eca877a5a1457cf245197103a38bee2c8 /sys-apps/hwinfo
parentnet-misc/connman: add 1.42_pre20220801 (diff)
downloadgentoo-c5cade04db2e914a4a29c219743fd601c914fc2b.tar.gz
gentoo-c5cade04db2e914a4a29c219743fd601c914fc2b.tar.bz2
gentoo-c5cade04db2e914a4a29c219743fd601c914fc2b.zip
sys-apps/hwinfo: add 22.0
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-apps/hwinfo')
-rw-r--r--sys-apps/hwinfo/Manifest1
-rw-r--r--sys-apps/hwinfo/files/hwinfo-22.0-glibc-2.36.patch30
-rw-r--r--sys-apps/hwinfo/hwinfo-22.0.ebuild63
3 files changed, 94 insertions, 0 deletions
diff --git a/sys-apps/hwinfo/Manifest b/sys-apps/hwinfo/Manifest
index e83fa3d068c0..e17ac8bdb782 100644
--- a/sys-apps/hwinfo/Manifest
+++ b/sys-apps/hwinfo/Manifest
@@ -1,3 +1,4 @@
DIST hwinfo-21.80-1.1.src.rpm 968192 BLAKE2B a11a1060137ff89504963c01c4129dcac93e8eea9747ea20272763f648068e8b4fb3f1c31ae761664b1b1ffedf32971b3b27804f125473f0367cc6eed03751bf SHA512 7bf64d9ee6b2381c43ffb22dc5623c8a8ed05c26b4e154c3093a9cb255779a1d482c18cd085b272ce619249743f1c43989337bed142685b4d6c634f4551893ee
DIST hwinfo-21.81-1.3.src.rpm 967951 BLAKE2B af6c390cd327ac2683f6b92a7847c5a0dc99e7553e35b7a5fd07db0a7f60c671a303e85061e1656474792b921e0d1b8ad18591f22a5da557879743d91151509a SHA512 eef89b5c8c029f606d66eb1740c4d046baaf490fc39d42d0137d1c4c5b248b0ddbe34b1532dbcef10f408677f173cfeb11d4c3e801a6a90280e1a6babc245674
DIST hwinfo-21.82-1.1.src.rpm 968922 BLAKE2B 5a491e7ca7125b40205dfa0e28350124f3deab6438424289ec44588940c47ddd341c9a7705edd3b9678b80050e26acdad1e9ea4aa7bc47e1af670ae020bfec51 SHA512 7221430e67bd76016d535db823e5e66034001c24e49de656365b421ef528bdcdf94ad82399f6a5916e55dc0b9f2dc1873a0e9ae2813025b746999bb2c5bd02df
+DIST hwinfo-22.0-1.1.src.rpm 968737 BLAKE2B a4c252b97539ce97a4d56e543c08ea6804dc2678f47d6d60506913e6e26f3f797a61c1613d20d870ec4da7b48c400bb443e7a55ad374c2c0486e5c0d3dca9c7a SHA512 c53f1a1b1dcb9c7e07476a553c86663055853d0e1fffa1d5125b944e63d4f019e992c5ebf5cbbb2685428184bff569f5eb368172535dc2531b38f4d31180753d
diff --git a/sys-apps/hwinfo/files/hwinfo-22.0-glibc-2.36.patch b/sys-apps/hwinfo/files/hwinfo-22.0-glibc-2.36.patch
new file mode 100644
index 000000000000..e22bc78120c1
--- /dev/null
+++ b/sys-apps/hwinfo/files/hwinfo-22.0-glibc-2.36.patch
@@ -0,0 +1,30 @@
+From 327942b7090e77a2a6baac18504ddb3dd3480df3 Mon Sep 17 00:00:00 2001
+From: WANG Xuerui <xen0n@gentoo.org>
+Date: Sat, 6 Aug 2022 18:04:55 +0800
+Subject: [PATCH] fix build with glibc-2.36
+
+See section 2.1 of https://sourceware.org/glibc/wiki/Release/2.36
+("Usage of <linux/mount.h> and <sys/mount.h>") for details.
+
+Also, remove a couple of ancient hacks that are no longer relevant after
+the removal of <linux/fs.h> inclusion.
+
+Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
+---
+ src/hd/hd.c | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/src/hd/hd.c b/src/hd/hd.c
+index fa0a5089..159bfaab 100644
+--- a/src/hd/hd.c
++++ b/src/hd/hd.c
+@@ -21,9 +21,6 @@
+ #include <sys/mman.h>
+ #include <linux/pci.h>
+ #include <linux/hdreg.h>
+-#define _LINUX_AUDIT_H_
+-#define _LINUX_PRIO_TREE_H
+-#include <linux/fs.h>
+
+ /**
+ * @defgroup libhdBUSint Bus scanning code
diff --git a/sys-apps/hwinfo/hwinfo-22.0.ebuild b/sys-apps/hwinfo/hwinfo-22.0.ebuild
new file mode 100644
index 000000000000..d99dfc1dfa86
--- /dev/null
+++ b/sys-apps/hwinfo/hwinfo-22.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit rpm toolchain-funcs
+
+DESCRIPTION="Hardware detection tool used in SuSE Linux"
+HOMEPAGE="https://github.com/openSUSE/hwinfo/"
+#Using srpms from SUSE to get pregenerated changelog, otherwise we could use GH
+#SRC_URI="https://github.com/openSUSE/hwinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="http://download.opensuse.org/tumbleweed/repo/src-oss/src/${P}-1.1.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ amd64? ( dev-libs/libx86emu )
+ x86? ( dev-libs/libx86emu )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ >=sys-kernel/linux-headers-2.6.17"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+PATCHES=( "${FILESDIR}"/${P}-glibc-2.36.patch )
+
+src_prepare() {
+ # Respect AR variable.
+ sed -i \
+ -e 's:ar r:$(AR) r:' \
+ src/{,isdn,ids,smp,hd}/Makefile || die
+
+ # Respect LDFLAGS.
+ sed -i -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' src/ids/Makefile || die
+
+ # Respect MAKE variable. Skip forced -pipe and -g. Respect LDFLAGS.
+ sed -i \
+ -e 's:make:$(MAKE):' \
+ -e 's:-pipe -g::' \
+ -e 's:LDFLAGS.*=:LDFLAGS +=:' \
+ Makefile{,.common} || die
+ # Workaround from Arch, if using source tarballs from github
+ # echo 'touch changelog' > git2log
+ default
+}
+
+src_compile() {
+ tc-export AR
+ emake CC="$(tc-getCC)" RPM_OPT_FLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+ keepdir /var/lib/hardware/udi
+
+ dodoc changelog README*
+ docinto examples
+ dodoc doc/example*.c
+ doman doc/*.{1,8}
+}