summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Rosenthal <jrosenth@chromium.org>2024-04-04 11:14:09 -0600
committerJoonas Niilola <juippis@gentoo.org>2024-05-27 19:14:14 +0300
commitaac6041b8bab1aff33e29c00e4c9babcf6e7e3f9 (patch)
tree24c16dcaadc0355eb8400546036df24df19da211 /sys-apps/i2c-tools
parentdev-libs/protobuf: add 26.1 (diff)
downloadgentoo-aac6041b8bab1aff33e29c00e4c9babcf6e7e3f9.tar.gz
gentoo-aac6041b8bab1aff33e29c00e4c9babcf6e7e3f9.tar.bz2
gentoo-aac6041b8bab1aff33e29c00e4c9babcf6e7e3f9.zip
sys-apps/i2c-tools: Add 32-bit LFS support
The i2c-tools build doesn't natively support 32-bit LFS. Call append-lfs-flags to bring it in. Additionally, it appears the Makefile ignores CPPFLAGS, so hack that into CFLAGS. Signed-off-by: Jack Rosenthal <jrosenth@chromium.org> Closes: https://github.com/gentoo/gentoo/pull/36103 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-apps/i2c-tools')
-rw-r--r--sys-apps/i2c-tools/i2c-tools-4.3-r2.ebuild (renamed from sys-apps/i2c-tools/i2c-tools-4.3-r1.ebuild)3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-apps/i2c-tools/i2c-tools-4.3-r1.ebuild b/sys-apps/i2c-tools/i2c-tools-4.3-r2.ebuild
index e0211bd875af..a76b3146c129 100644
--- a/sys-apps/i2c-tools/i2c-tools-4.3-r1.ebuild
+++ b/sys-apps/i2c-tools/i2c-tools-4.3-r2.ebuild
@@ -36,13 +36,14 @@ src_prepare() {
src_configure() {
use python && distutils-r1_src_configure
+ append-lfs-flags
export BUILD_DYNAMIC_LIB=1
export USE_STATIC_LIB=0
export BUILD_STATIC_LIB=0
}
src_compile() {
- emake AR="$(tc-getAR)" CC="$(tc-getCC)" EXTRA="eeprog"
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${CPPFLAGS}" EXTRA="eeprog"
if use python ; then
cd py-smbus || die