summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-12 04:57:09 +0000
committerSam James <sam@gentoo.org>2023-12-12 04:57:09 +0000
commit03be10df9dd6b8f85909de2a042e2a86f2f0aa01 (patch)
tree281b4e1a8ff29a81a9f7b308912b7f3d67d70e8d /sys-apps/kbd
parentsys-fs/zfs: Stabilize 2.1.14 arm64, #919746 (diff)
downloadgentoo-03be10df9dd6b8f85909de2a042e2a86f2f0aa01.tar.gz
gentoo-03be10df9dd6b8f85909de2a042e2a86f2f0aa01.tar.bz2
gentoo-03be10df9dd6b8f85909de2a042e2a86f2f0aa01.zip
sys-apps/kbd: add 2.6.4
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/kbd')
-rw-r--r--sys-apps/kbd/Manifest1
-rw-r--r--sys-apps/kbd/kbd-2.6.4.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/sys-apps/kbd/Manifest b/sys-apps/kbd/Manifest
index 4763bd1a80fc..5ed51b0457da 100644
--- a/sys-apps/kbd/Manifest
+++ b/sys-apps/kbd/Manifest
@@ -2,3 +2,4 @@ DIST kbd-2.5.1.tar.xz 1491952 BLAKE2B aab4c3d78c28709bf562b54fe94c0533d5c33185e1
DIST kbd-2.6.1.tar.xz 1591240 BLAKE2B 15c738379cfa9420e218ddbf6562e2c75b6bf5eb31ce159d798d49546991ca0c02bf9a11486d99bd2ba7d99f3bf6abb53ad799c6314df6d9ca9b1e8cf808b738 SHA512 8d7f39efa91ef16f4c0601c1744e7f00e411c121607660c8f585d3e085d8e8bea4ea095f6c7f491af763097a9844fb4a07d4b78a8358cb7caafbfda0626acf91
DIST kbd-2.6.2.tar.xz 1503532 BLAKE2B aa146177b2ffd9d6d396c253ce54d0ee42e1a1a2ba471ae0f8950a72b49f2f83aa4660337a581150cfd9fae0b9a4415725f4d152e83c0bdf26b833a31f6e2696 SHA512 afcac33e2e8eecd6f9cfa20bb39254deffc4d8924c4f722d003bdfaf286dac7d87f55ed0a5a35d341ae88fc48162966d5aa1ab8125b11e845bf3c2589a17c8d2
DIST kbd-2.6.3.tar.xz 1503048 BLAKE2B 9c3f9e2ec9abd3a18bd4159b3a223deee6aee74610ed843582dc2a0397bb80075ae5e76a67d030fcd7a706641a8fb4604840eec67057271ce3e75a0630145942 SHA512 7daf59557408e1cd29140130094b43d8d89b25b3094fd03912d878483f27d128ad25163ea7023e5a10b7d8b8bf8434447927b69fe0094f8db97484881f23ed60
+DIST kbd-2.6.4.tar.xz 1504584 BLAKE2B 25e55be0210c206c1f5eb0d85045bb1cbb2442cf88fb7eb28f7bbb8dd0d86473f48444fd9d80dfc624ce7ba8b39bfe1152ee6cf1877fab444e09600e93dae0ee SHA512 a4149cb0f85fd79b333a6c137d70896a30ebceb1cf9d4b5eef3abb2e1866d83b46cee651e4f3e512bf7e0ccd232d955c14f693e57020a3626e4943c4695fc8ab
diff --git a/sys-apps/kbd/kbd-2.6.4.ebuild b/sys-apps/kbd/kbd-2.6.4.ebuild
new file mode 100644
index 000000000000..23a50e0bfa38
--- /dev/null
+++ b/sys-apps/kbd/kbd-2.6.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/legionus/kbd.git https://git.kernel.org/pub/scm/linux/kernel/git/legion/kbd.git"
+ EGIT_BRANCH="master"
+else
+ if [[ $(ver_cut 3) -lt 90 ]] ; then
+ SRC_URI="https://www.kernel.org/pub/linux/utils/kbd/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ else
+ inherit autotools
+ SRC_URI="https://github.com/legionus/kbd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ fi
+fi
+
+DESCRIPTION="Keyboard and console utilities"
+HOMEPAGE="https://kbd-project.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls selinux pam test"
+RESTRICT="!test? ( test )"
+
+# Testsuite's Makefile.am calls missing(!)
+# ... but this seems to be consistent with the autoconf docs?
+# Needs more investigation: https://www.gnu.org/software/autoconf/manual/autoconf-2.67/html_node/autom4te-Invocation.html
+QA_AM_MAINTAINER_MODE=".*--run autom4te --language=autotest.*"
+
+DEPEND="
+ app-alternatives/gzip
+ pam? (
+ !app-misc/vlock
+ sys-libs/pam
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-loadkeys )
+"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+"
+
+src_prepare() {
+ default
+
+ # Rename conflicting keymaps to have unique names, bug #293228
+ # See also https://github.com/legionus/kbd/issues/76.
+ pushd "${S}"/data/keymaps/i386 &> /dev/null || die
+ mv fgGIod/trf.map fgGIod/trf-fgGIod.map || die
+ mv olpc/es.map olpc/es-olpc.map || die
+ mv olpc/pt.map olpc/pt-olpc.map || die
+ mv qwerty/cz.map qwerty/cz-qwerty.map || die
+ popd &> /dev/null || die
+
+ if [[ ${PV} == 9999 ]] || [[ $(ver_cut 3) -ge 90 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-werror
+
+ $(use_enable nls)
+ $(use_enable pam vlock)
+ $(use_enable test tests)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc docs/doc/*.html
+
+ # USE="test" installs .la files
+ find "${ED}" -type f -name "*.la" -delete || die
+}