summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-28 04:02:32 +0000
committerSam James <sam@gentoo.org>2023-12-28 04:02:32 +0000
commitfac38f9faae091fcff74b092b58bbfc8c9cc0cd8 (patch)
treebe7929247afc0252853058f2385a630bbbe4b8b0 /sys-apps/less
parentnet-misc/wget: drop 1.21.3-r1 (diff)
downloadgentoo-fac38f9faae091fcff74b092b58bbfc8c9cc0cd8.tar.gz
gentoo-fac38f9faae091fcff74b092b58bbfc8c9cc0cd8.tar.bz2
gentoo-fac38f9faae091fcff74b092b58bbfc8c9cc0cd8.zip
sys-apps/less: drop 633-r2, 643
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/less')
-rw-r--r--sys-apps/less/less-633-r2.ebuild86
-rw-r--r--sys-apps/less/less-643.ebuild93
2 files changed, 0 insertions, 179 deletions
diff --git a/sys-apps/less/less-633-r2.ebuild b/sys-apps/less/less-633-r2.ebuild
deleted file mode 100644
index 5d22949f4f80..000000000000
--- a/sys-apps/less/less-633-r2.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-WANT_AUTOMAKE=none
-WANT_LIBTOOL=none
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/gwsw/less"
- inherit git-r3
-fi
-
-inherit autotools flag-o-matic optfeature
-
-# Releases are usually first a beta then promoted to stable if no
-# issues were found. Upstream explicitly ask "to not generally distribute"
-# the beta versions. It's okay to keyword beta versions if they fix
-# a serious bug, but otherwise try to avoid it.
-
-MY_PV=${PV/_beta/-beta}
-MY_P=${PN}-${MY_PV}
-DESCRIPTION="Excellent text file viewer"
-HOMEPAGE="https://www.greenwoodsoftware.com/less/"
-[[ ${PV} != 9999 ]] && SRC_URI="https://www.greenwoodsoftware.com/less/${MY_P}.tar.gz"
-S="${WORKDIR}"/${MY_P/?beta}
-
-LICENSE="|| ( GPL-3 BSD-2 )"
-SLOT="0"
-if [[ ${PV} != 9999 && ${PV} != *_beta* ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-fi
-IUSE="pcre"
-# As of 623_beta, lesstest is not included in dist tarballs
-# https://github.com/gwsw/less/issues/344
-RESTRICT="test"
-
-DEPEND="
- >=app-misc/editor-wrapper-3
- >=sys-libs/ncurses-5.2:=
- pcre? ( dev-libs/libpcre2 )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-633-tinfow.patch
-)
-
-src_prepare() {
- default
- # Per upstream README to prepare live build
- [[ ${PV} == 9999 ]] && emake -f Makefile.aut distfiles
- # Upstream uses unpatched autoconf-2.69, which breaks with clang-16.
- # https://bugs.gentoo.org/870412
- eautoreconf
-}
-
-src_configure() {
- append-lfs-flags # bug #896316
-
- local myeconfargs=(
- --with-regex=$(usex pcre pcre2 posix)
- --with-editor="${EPREFIX}"/usr/libexec/editor
- )
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- emake check VERBOSE=1
-}
-
-src_install() {
- default
-
- newbin "${FILESDIR}"/lesspipe-r2.sh lesspipe
- newenvd "${FILESDIR}"/less.envd 70less
-}
-
-pkg_preinst() {
- optfeature "Colorized output supprt" dev-python/pygments
-
- if has_version "<${CATEGORY}/${PN}-483-r1" ; then
- elog "The lesspipe.sh symlink has been dropped. If you are still setting"
- elog "LESSOPEN to that, you will need to update it to '|lesspipe %s'."
- fi
-}
diff --git a/sys-apps/less/less-643.ebuild b/sys-apps/less/less-643.ebuild
deleted file mode 100644
index 559db6a78878..000000000000
--- a/sys-apps/less/less-643.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Releases are usually first a beta then promoted to stable if no
-# issues were found. Upstream explicitly ask "to not generally distribute"
-# the beta versions. It's okay to keyword beta versions if they fix
-# a serious bug, but otherwise try to avoid it.
-
-WANT_AUTOMAKE=none
-WANT_LIBTOOL=none
-inherit autotools flag-o-matic optfeature toolchain-funcs
-
-DESCRIPTION="Excellent text file viewer"
-HOMEPAGE="https://www.greenwoodsoftware.com/less/"
-
-MY_PV=${PV/_beta/-beta}
-MY_P=${PN}-${MY_PV}
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/gwsw/less"
- inherit git-r3
-else
- SRC_URI="https://www.greenwoodsoftware.com/less/${MY_P}.tar.gz"
-
- if [[ ${PV} != *_beta* ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
- fi
-fi
-
-S="${WORKDIR}"/${MY_P/?beta}
-
-LICENSE="|| ( GPL-3 BSD-2 )"
-SLOT="0"
-IUSE="pcre test"
-# chinese1, utf8-2
-RESTRICT="test !test? ( test )"
-
-DEPEND="
- >=app-misc/editor-wrapper-3
- >=sys-libs/ncurses-5.2:=
- pcre? ( dev-libs/libpcre2 )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="test? ( virtual/pkgconfig )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-643-lesstest-pkg-config.patch
-)
-
-src_prepare() {
- default
- # Per upstream README to prepare live build
- [[ ${PV} == 9999 ]] && emake -f Makefile.aut distfiles
- # Upstream uses unpatched autoconf-2.69, which breaks with clang-16.
- # https://bugs.gentoo.org/870412
- eautoreconf
-}
-
-src_configure() {
- append-lfs-flags # bug #896316
-
- local myeconfargs=(
- --with-regex=$(usex pcre pcre2 posix)
- --with-editor="${EPREFIX}"/usr/libexec/editor
- )
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- emake check VERBOSE=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
-}
-
-src_install() {
- default
-
- newbin "${FILESDIR}"/lesspipe-r2.sh lesspipe
- newenvd "${FILESDIR}"/less.envd 70less
-}
-
-pkg_preinst() {
- optfeature "Colorized output supprt" dev-python/pygments
-
- if has_version "<${CATEGORY}/${PN}-483-r1" ; then
- elog "The lesspipe.sh symlink has been dropped. If you are still setting"
- elog "LESSOPEN to that, you will need to update it to '|lesspipe %s'."
- fi
-
- if has_version "<${CATEGORY}/${PN}-643" ; then
- elog "less now colorizes by default. To disable this, set LESSCOLOR=no."
- fi
-}