summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-28 09:35:05 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-28 10:01:24 +0200
commit55eedf6cb6501890f46709b0e59d7157f92b2fb8 (patch)
tree412cbd3aa060544eab750c97a2a6194ec6aa1346 /sys-apps/pkgcore
parentdev-python/websockets: x86 stable wrt bug #792564 (diff)
downloadgentoo-55eedf6cb6501890f46709b0e59d7157f92b2fb8.tar.gz
gentoo-55eedf6cb6501890f46709b0e59d7157f92b2fb8.tar.bz2
gentoo-55eedf6cb6501890f46709b0e59d7157f92b2fb8.zip
sys-apps/pkgcore: Bump to 0.12.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-apps/pkgcore')
-rw-r--r--sys-apps/pkgcore/Manifest1
-rw-r--r--sys-apps/pkgcore/pkgcore-0.12.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/pkgcore/Manifest b/sys-apps/pkgcore/Manifest
index 4a735e480fe3..4e05da8f227c 100644
--- a/sys-apps/pkgcore/Manifest
+++ b/sys-apps/pkgcore/Manifest
@@ -1,3 +1,4 @@
DIST pkgcore-0.11.6.tar.gz 634191 BLAKE2B c06f24006be697771dd3d7569e3a27310dca56c05047ac991c2db359838dddd5eec78c8d424e826b39968cc496be6e7eb366668bfa45082aac438b663015cb8a SHA512 e556d20100c0234d319ed2e15686a3bb9f388f1cdefd7188958c3c0b32d741dd531cbbe8d377b0736662f66b3241e633491a72a1ce84dd86790e9f543b3d0800
DIST pkgcore-0.11.8.tar.gz 631665 BLAKE2B 1e33ce394c1df9418d22fc8653fca4da1b4e27d53325167e3b7231fb8382f3c81daa7a93587ab2226116865546d4ca1ae1dd4265ccc2adc9cb9b27106d9c352b SHA512 42ed7c54db5fa48dffa5e3927afae32d1b4db92da41eff99c8eaa10232fdeae4e0f3f4d39b1e1b4e3881304523822a9a99575648809c554e3bdcf59d9eab485b
DIST pkgcore-0.12.0.tar.gz 621376 BLAKE2B d58390ad7251fc48465d744a0b0694210d1f1cf505b072c06dc9731819b327b1edfa60d0f89db113852c87109c6340c8c13c72ae2d89b517d5fca34b53632b6b SHA512 d066a2f2deb4f654b04f9e78d37bf88a97f67f0396f5867ffe3a18f8c0d6459d73721b66cad52a50581ee10420694a1fd195b28a013b3a97cb1ebf08bc59598b
+DIST pkgcore-0.12.1.tar.gz 621918 BLAKE2B aa3bedaf4d58d8e604b19ce3e6f97242d29eadbbeab85b7de029d0230a5ea77e2ee96b128381964afe92a327674d64878f833d8c1ddc983c0fe1381b008e2d62 SHA512 a78f3ffd5610f14adb07e2adce07c8446012e742c777d08bbc7ac711bf194508d66a14d21aa56f5d0c9353bd10354fdd34bc6eb4b6017c03bff5d1b565a53575
diff --git a/sys-apps/pkgcore/pkgcore-0.12.1.ebuild b/sys-apps/pkgcore/pkgcore-0.12.1.ebuild
new file mode 100644
index 000000000000..864adb52ae14
--- /dev/null
+++ b/sys-apps/pkgcore/pkgcore-0.12.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pkgcore.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a framework for package management"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND+=" >=dev-python/snakeoil-0.9.6[${PYTHON_USEDEP}]"
+fi
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests setup.py
+
+src_test() {
+ local -x PYTHONDONTWRITEBYTECODE=
+ distutils-r1_src_test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
+ distutils-r1_python_install_all
+}