summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2020-09-01 20:42:21 +0000
committerJason Zaman <perfinion@gentoo.org>2020-09-14 20:40:25 -0700
commitc395a2723620f5f2f97830fb3b1bb984c2b79168 (patch)
tree835cfc82f8a0dac8ce216d8acc2079499b636adc /sys-apps/semodule-utils
parentsys-apps/selinux-python: Version bump to 3.1. (diff)
downloadgentoo-c395a2723620f5f2f97830fb3b1bb984c2b79168.tar.gz
gentoo-c395a2723620f5f2f97830fb3b1bb984c2b79168.tar.bz2
gentoo-c395a2723620f5f2f97830fb3b1bb984c2b79168.zip
sys-apps/semodule-utils: Version bump to 3.1.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps/semodule-utils')
-rw-r--r--sys-apps/semodule-utils/Manifest1
-rw-r--r--sys-apps/semodule-utils/semodule-utils-3.1.ebuild47
-rw-r--r--sys-apps/semodule-utils/semodule-utils-9999.ebuild12
3 files changed, 53 insertions, 7 deletions
diff --git a/sys-apps/semodule-utils/Manifest b/sys-apps/semodule-utils/Manifest
index 4bb706757fe3..09aa9e42f0ed 100644
--- a/sys-apps/semodule-utils/Manifest
+++ b/sys-apps/semodule-utils/Manifest
@@ -1,2 +1,3 @@
DIST semodule-utils-2.9.tar.gz 14259 BLAKE2B f72630c520504596171ac6f678b1fde2bb8482b620f0d8f6374c59b85d634ee8c407e3e4b268dae4d6cecfa2749b26f8808dd56f7c5391e7d1ba11f4a8a789e5 SHA512 688f1fcb34042b837019302debda76847691657709130b99bf937a85774a0ae69d789ee82b0633a4d2dc661dc6d0a1706a878ac681317df2abe68418bec3f952
DIST semodule-utils-3.0.tar.gz 14263 BLAKE2B 119f40b34184e2cb0719e6a34ffb026f23c172f74d8ca3812220785381fabc5c3761865ec3b211f03f5c96b9ae0081341a661c2be78198171b09c99b37bb0716 SHA512 004e8f02f7e7e6f016b2b5a1a7720a87409d77d0040f7df830cf73808c9f8e3d87b41a7cea273420909971ce8bcc6540d5a46bd25be8c032b12257b4861e1769
+DIST semodule-utils-3.1.tar.gz 14257 BLAKE2B c8c9a1ce7c9c4f53b1f4c728d16b149fdc284f4cff8b4fce0cb59b77d37d6d7e9bf2102c7177c4eaf94677af6147e42d8d0bd55c0bf3a358968d0162d5a6c65a SHA512 b92794bbfbce5834ee7f62fddb40b5506e9291e8fa7c5d669b2e281089b8f8dc40c4522ea287ac5deffdaee751442ba8e691e2ac45fdd378b60d5d6b2527d157
diff --git a/sys-apps/semodule-utils/semodule-utils-3.1.ebuild b/sys-apps/semodule-utils/semodule-utils-3.1.ebuild
new file mode 100644
index 000000000000..db1d166cceb3
--- /dev/null
+++ b/sys-apps/semodule-utils/semodule-utils-3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+MY_RELEASEDATE="20200710"
+SEPOL_VER="${PV}"
+SELNX_VER="${PV}"
+
+MY_P="${P//_/-}"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="SELinux policy module utilities"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${SEPOL_VER}:="
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
diff --git a/sys-apps/semodule-utils/semodule-utils-9999.ebuild b/sys-apps/semodule-utils/semodule-utils-9999.ebuild
index dfe7c8bdc466..db1d166cceb3 100644
--- a/sys-apps/semodule-utils/semodule-utils-9999.ebuild
+++ b/sys-apps/semodule-utils/semodule-utils-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
inherit toolchain-funcs
-MY_RELEASEDATE="20191204"
+MY_RELEASEDATE="20200710"
SEPOL_VER="${PV}"
SELNX_VER="${PV}"
@@ -30,8 +30,7 @@ SLOT="0"
DEPEND=">=sys-libs/libsepol-${SEPOL_VER}:="
-RDEPEND="${DEPEND}
- !<sys-apps/policycoreutils-2.7_pre"
+RDEPEND="${DEPEND}"
src_prepare() {
default
@@ -44,6 +43,5 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" \
- install
+ emake DESTDIR="${D}" install
}