summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-05-28 06:33:36 +0000
committerSam James <sam@gentoo.org>2024-05-09 02:13:08 +0100
commitcf89ce244af18d0d54ed206ddac1dff02f687a88 (patch)
treece1bd3e63d7089864ef05f1170400676a2dac3b2 /sys-apps/utempter
parentapp-text/crf++: Removing register keywords (diff)
downloadgentoo-cf89ce244af18d0d54ed206ddac1dff02f687a88.tar.gz
gentoo-cf89ce244af18d0d54ed206ddac1dff02f687a88.tar.bz2
gentoo-cf89ce244af18d0d54ed206ddac1dff02f687a88.zip
sys-apps/utempter: Fix undeclared gettimeofday
Closes: https://bugs.gentoo.org/898552 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31197 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/utempter')
-rw-r--r--sys-apps/utempter/files/utempter-0.5.5.6-no_gettimeofday.patch23
-rw-r--r--sys-apps/utempter/utempter-0.5.5.6-r2.ebuild50
2 files changed, 73 insertions, 0 deletions
diff --git a/sys-apps/utempter/files/utempter-0.5.5.6-no_gettimeofday.patch b/sys-apps/utempter/files/utempter-0.5.5.6-no_gettimeofday.patch
new file mode 100644
index 000000000000..26bfdb9e9eb0
--- /dev/null
+++ b/sys-apps/utempter/files/utempter-0.5.5.6-no_gettimeofday.patch
@@ -0,0 +1,23 @@
+From: Brahmajit Das <brahmajit.xyz@gmail.com>
+Date: Sun, 28 May 2023 06:25:33 +0000
+Subject: [PATCH] Fix undeclared funtion gettimeofday.
+
+Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com>
+---
+ utempter.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/utempter.c b/utempter.c
+index 3f2f3a2..13214cc 100644
+--- a/utempter.c
++++ b/utempter.c
+@@ -11,6 +11,7 @@
+ #include <sys/stat.h>
+ #include <sys/sysmacros.h>
+ #include <utmp.h>
++#include <sys/time.h>
+ #ifndef __UCLIBC__
+ #include <utmpx.h>
+ #endif
+--
+2.40.1
diff --git a/sys-apps/utempter/utempter-0.5.5.6-r2.ebuild b/sys-apps/utempter/utempter-0.5.5.6-r2.ebuild
new file mode 100644
index 000000000000..92d7dd374dd3
--- /dev/null
+++ b/sys-apps/utempter/utempter-0.5.5.6-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${P%.*}"
+MY_P="${MY_PN}-${PV##*.}"
+
+inherit flag-o-matic rpm toolchain-funcs
+
+DESCRIPTION="App that allows non-privileged apps to write utmp (login) info"
+HOMEPAGE="https://www.redhat.com/"
+SRC_URI="mirror://gentoo/${MY_P}.src.rpm"
+S="${WORKDIR}/${MY_PN}"
+
+LICENSE="|| ( MIT LGPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+BDEPEND="acct-group/utmp"
+RDEPEND="
+ ${BDEPEND}
+ !sys-libs/libutempter
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.5.6-no_utmpx.patch
+ "${FILESDIR}"/${PN}-0.5.5.6-fix-build-system.patch
+ "${FILESDIR}"/${PN}-0.5.5.6-no_gettimeofday.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+ append-cflags -Wall
+}
+
+src_install() {
+ local myemakeargs=(
+ LIBDIR="/usr/$(get_libdir)"
+ RPM_BUILD_ROOT="${ED}"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ dobin utmp
+
+ fowners root:utmp /usr/sbin/utempter
+ fperms 2755 /usr/sbin/utempter
+}