summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-05-21 07:05:04 +0300
committerFlorian Schmaus <flow@gentoo.org>2024-05-23 11:14:00 +0200
commit19698cdcc9acce2f1a3df50742a0f1c40fcdd52d (patch)
tree3d97e52269cf215c5625cd285e8a4df6f7cb8493 /sys-apps
parentsci-mathematics/ginac: BDEPEND on media-gfx/fig2dev (diff)
downloadgentoo-19698cdcc9acce2f1a3df50742a0f1c40fcdd52d.tar.gz
gentoo-19698cdcc9acce2f1a3df50742a0f1c40fcdd52d.tar.bz2
gentoo-19698cdcc9acce2f1a3df50742a0f1c40fcdd52d.zip
sys-apps/proot: handle docutils-0.21 dropping console scripts
Closes: https://bugs.gentoo.org/930449 Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/36756 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/proot/proot-5.3.0.ebuild9
-rw-r--r--sys-apps/proot/proot-5.4.0.ebuild9
2 files changed, 16 insertions, 2 deletions
diff --git a/sys-apps/proot/proot-5.3.0.ebuild b/sys-apps/proot/proot-5.3.0.ebuild
index c567f39e0bf8..f7271b5c931f 100644
--- a/sys-apps/proot/proot-5.3.0.ebuild
+++ b/sys-apps/proot/proot-5.3.0.ebuild
@@ -42,7 +42,14 @@ src_compile() {
CHECK_VERSION="true" \
CAREBUILDENV="ok" \
proot $(use care && echo "care")
- emake -C doc SUFFIX=".py" proot/man.1
+
+ # Docutils >=0.21 dropped .py console scripts
+ # bug #930449
+ if has_version ">=dev-python/docutils-0.21" ; then
+ emake -C doc proot/man.1
+ else
+ emake -C doc SUFFIX=".py" proot/man.1
+ fi
}
src_install() {
diff --git a/sys-apps/proot/proot-5.4.0.ebuild b/sys-apps/proot/proot-5.4.0.ebuild
index e7fd0dc982cc..1ebb99466a25 100644
--- a/sys-apps/proot/proot-5.4.0.ebuild
+++ b/sys-apps/proot/proot-5.4.0.ebuild
@@ -42,7 +42,14 @@ src_compile() {
CHECK_VERSION="true" \
CAREBUILDENV="ok" \
proot $(use care && echo "care")
- emake -C doc SUFFIX=".py" proot/man.1
+
+ # Docutils >=0.21 dropped .py console scripts
+ # bug #930449
+ if has_version ">=dev-python/docutils-0.21" ; then
+ emake -C doc proot/man.1
+ else
+ emake -C doc SUFFIX=".py" proot/man.1
+ fi
}
src_install() {