summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-02-24 11:38:37 +0000
committerMarek Szuba <marecki@gentoo.org>2023-02-24 16:49:56 +0000
commit2c97f3a2803370134a89c1df8f2110f24e7cef4c (patch)
tree5954c8ca3c0fff9879d1bd5dba3844285062c615 /sys-apps
parentsys-apps/fwupd: drop 1.8.5, 1.8.7, 1.8.8-r1 (diff)
downloadgentoo-2c97f3a2803370134a89c1df8f2110f24e7cef4c.tar.gz
gentoo-2c97f3a2803370134a89c1df8f2110f24e7cef4c.tar.bz2
gentoo-2c97f3a2803370134a89c1df8f2110f24e7cef4c.zip
sys-apps/fwupd: add 1.8.11
Closes: https://bugs.gentoo.org/895716 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/fwupd/Manifest1
-rw-r--r--sys-apps/fwupd/files/fwupd-1.8.11-installed_tests.patch406
-rw-r--r--sys-apps/fwupd/fwupd-1.8.11.ebuild197
3 files changed, 604 insertions, 0 deletions
diff --git a/sys-apps/fwupd/Manifest b/sys-apps/fwupd/Manifest
index cb11cb0f4dcf..d71556e833d1 100644
--- a/sys-apps/fwupd/Manifest
+++ b/sys-apps/fwupd/Manifest
@@ -1 +1,2 @@
DIST fwupd-1.8.10.tar.xz 3366400 BLAKE2B 891cade6c4a3a58d61c19ba6001d0161de046465729ebd349d04b2e2170146d2a7dc099285f60f7b1f7438d70a7792b5ff3921a2892e726cc6674f0628f9fabc SHA512 8437cdc93d553e42d33a037d14fcb09bb65b4c4d7d60add6a90c84dce0845097fe96005a1f6a9da7daf89df5b7dcd1b43a9fbba666cd18129b67ebe1c3ce7c97
+DIST fwupd-1.8.11.tar.xz 3389224 BLAKE2B d86b8776f78405384fcced78ebe1478585a4ca5127a184d357f2b8fc78f6437a58030c81f5bae672564e2a0df85d9b8512869b7eb1b82f5099bd0c4269acebc5 SHA512 f1fe648e33dc407bbb2ab438a29dee6e29ccdfa8cb6ca421b92cdfd724a3347254e6ddf35634b1e41e985558ea95166914b3fde927f61f1c0aa29800bf6ca6de
diff --git a/sys-apps/fwupd/files/fwupd-1.8.11-installed_tests.patch b/sys-apps/fwupd/files/fwupd-1.8.11-installed_tests.patch
new file mode 100644
index 000000000000..819b6799ebdf
--- /dev/null
+++ b/sys-apps/fwupd/files/fwupd-1.8.11-installed_tests.patch
@@ -0,0 +1,406 @@
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -10,20 +10,10 @@
+ subdir('fish-completion')
+ endif
+
+-if get_option('tests')
+-subdir('device-tests')
+-endif
+-
+ if build_daemon
+ subdir('motd')
+ endif
+
+-if get_option('tests')
+- if build_daemon
+- subdir('installed-tests')
+- endif
+-endif
+-
+ if build_standalone
+ install_data(['daemon.conf'],
+ install_dir: join_paths(sysconfdir, 'fwupd')
+--- a/libfwupdplugin/meson.build
++++ b/libfwupdplugin/meson.build
+@@ -370,6 +370,7 @@
+ )
+ test('fwupdplugin-self-test', e, is_parallel: false, timeout: 180, env: env)
+
++ if false
+ install_data([
+ 'tests/chassis_type',
+ 'tests/sys_vendor',
+@@ -388,6 +389,7 @@
+ ],
+ install_dir: join_paths(installed_test_datadir, 'tests/dmi/tables64'),
+ )
++ endif
+ endif
+
+ fwupdplugin_incdir = include_directories('.')
+--- a/libfwupdplugin/tests/meson.build
++++ b/libfwupdplugin/tests/meson.build
+@@ -10,6 +10,5 @@
+ command: [
+ python3, '-m', 'zipfile', '-c', '@OUTPUT@', '@INPUT@',
+ ],
+- install: true,
+ install_dir: installed_test_datadir,
+ )
+--- a/plugins/acpi-dmar/meson.build
++++ b/plugins/acpi-dmar/meson.build
+@@ -28,7 +28,6 @@
+ plugin_libs,
+ plugin_builtin_acpi_dmar,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/acpi-facp/meson.build
++++ b/plugins/acpi-facp/meson.build
+@@ -28,7 +28,6 @@
+ plugin_libs,
+ plugin_builtin_acpi_facp,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/acpi-ivrs/meson.build
++++ b/plugins/acpi-ivrs/meson.build
+@@ -28,7 +28,6 @@
+ plugin_libs,
+ plugin_builtin_acpi_ivrs,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/acpi-phat/meson.build
++++ b/plugins/acpi-phat/meson.build
+@@ -31,7 +31,6 @@
+ plugin_libs,
+ plugin_builtin_acpi_phat,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/ata/meson.build
++++ b/plugins/ata/meson.build
+@@ -33,7 +33,6 @@
+ plugin_libs,
+ plugin_builtin_ata,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/bcm57xx/meson.build
++++ b/plugins/bcm57xx/meson.build
+@@ -25,8 +25,6 @@
+ plugin_builtins += plugin_builtin_bcm57xx
+
+ if get_option('tests')
+- install_data(['tests/bcm57xx.builder.xml'],
+- install_dir: join_paths(installed_test_datadir, 'tests'))
+ env = environment()
+ env.set('G_TEST_SRCDIR', meson.current_source_dir())
+ env.set('G_TEST_BUILDDIR', meson.current_build_dir())
+@@ -41,7 +39,6 @@
+ plugin_libs,
+ plugin_builtin_bcm57xx,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/ccgx/meson.build
++++ b/plugins/ccgx/meson.build
+@@ -29,8 +29,6 @@
+ plugin_builtins += plugin_builtin_ccgx
+
+ if get_option('tests')
+- install_data(['tests/ccgx.builder.xml', 'tests/ccgx-dmc.builder.xml'],
+- install_dir: join_paths(installed_test_datadir, 'tests'))
+ env = environment()
+ env.set('G_TEST_SRCDIR', meson.current_source_dir())
+ env.set('G_TEST_BUILDDIR', meson.current_build_dir())
+@@ -45,7 +43,6 @@
+ plugin_libs,
+ plugin_builtin_ccgx,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/dfu/meson.build
++++ b/plugins/dfu/meson.build
+@@ -70,7 +70,6 @@
+ plugin_libs,
+ plugin_builtin_dfu,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/elantp/meson.build
++++ b/plugins/elantp/meson.build
+@@ -22,8 +22,6 @@
+ plugin_builtins += plugin_builtin_elantp
+
+ if get_option('tests')
+- install_data(['tests/elantp.builder.xml'],
+- install_dir: join_paths(installed_test_datadir, 'tests'))
+ env = environment()
+ env.set('G_TEST_SRCDIR', meson.current_source_dir())
+ env.set('G_TEST_BUILDDIR', meson.current_build_dir())
+@@ -38,7 +36,6 @@
+ plugin_libs,
+ plugin_builtin_elantp,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/linux-swap/meson.build
++++ b/plugins/linux-swap/meson.build
+@@ -28,7 +28,6 @@
+ plugin_libs,
+ plugin_builtin_linux_swap,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/mtd/meson.build
++++ b/plugins/mtd/meson.build
+@@ -30,7 +30,6 @@
+ plugin_libs,
+ plugin_builtin_mtd,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/nitrokey/meson.build
++++ b/plugins/nitrokey/meson.build
+@@ -33,7 +33,6 @@
+ plugin_libs,
+ plugin_builtin_nitrokey,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/nvme/meson.build
++++ b/plugins/nvme/meson.build
+@@ -38,7 +38,6 @@
+ plugin_libs,
+ plugin_builtin_nvme,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/pixart-rf/meson.build
++++ b/plugins/pixart-rf/meson.build
+@@ -19,8 +19,6 @@
+ plugin_builtins += plugin_builtin_pxi
+
+ if get_option('tests')
+- install_data(['tests/pixart.builder.xml'],
+- install_dir: join_paths(installed_test_datadir, 'tests'))
+ env = environment()
+ env.set('G_TEST_SRCDIR', meson.current_source_dir())
+ env.set('G_TEST_BUILDDIR', meson.current_build_dir())
+@@ -35,7 +33,6 @@
+ plugin_libs,
+ plugin_builtin_pxi,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/redfish/meson.build
++++ b/plugins/redfish/meson.build
+@@ -40,16 +40,6 @@
+ )
+
+ if get_option('tests')
+- install_data(['tests/redfish-smbios.bin'],
+- install_dir: join_paths(installed_test_datadir, 'tests'))
+- install_data(['tests/redfish.conf'],
+- install_dir: join_paths(installed_test_datadir, 'tests'),
+- install_mode: 'rw-r-----',
+- )
+- install_data(['tests/efi/efivars/RedfishIndications-16faa37e-4b6a-4891-9028-242de65a3b70'],
+- install_dir: join_paths(installed_test_datadir, 'tests', 'efi', 'efivars'))
+- install_data(['tests/efi/efivars/RedfishOSCredentials-16faa37e-4b6a-4891-9028-242de65a3b70'],
+- install_dir: join_paths(installed_test_datadir, 'tests', 'efi', 'efivars'))
+ env = environment()
+ env.set('G_TEST_SRCDIR', meson.current_source_dir())
+ env.set('G_TEST_BUILDDIR', meson.current_build_dir())
+@@ -70,7 +60,6 @@
+ fwupdplugin,
+ plugin_builtin_redfish,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/synaptics-mst/meson.build
++++ b/plugins/synaptics-mst/meson.build
+@@ -22,8 +22,6 @@
+ plugin_builtins += plugin_builtin_synaptics_mst
+
+ if get_option('tests')
+- install_data(['tests/synaptics-mst.builder.xml'],
+- install_dir: join_paths(installed_test_datadir, 'tests'))
+ env = environment()
+ env.set('G_TEST_SRCDIR', meson.current_source_dir())
+ env.set('G_TEST_BUILDDIR', meson.current_build_dir())
+@@ -47,7 +45,6 @@
+ c_args: [
+ cargs,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/synaptics-prometheus/meson.build
++++ b/plugins/synaptics-prometheus/meson.build
+@@ -18,8 +18,6 @@
+ plugin_builtins += plugin_builtin_synaprom
+
+ if get_option('tests')
+- install_data(['tests/synaptics-prometheus.builder.xml'],
+- install_dir: join_paths(installed_test_datadir, 'tests'))
+ env = environment()
+ env.set('G_TEST_SRCDIR', meson.current_source_dir())
+ env.set('G_TEST_BUILDDIR', meson.current_build_dir())
+@@ -35,7 +33,6 @@
+ plugin_builtin_synaprom,
+ ],
+ c_args: cargs,
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/synaptics-rmi/meson.build
++++ b/plugins/synaptics-rmi/meson.build
+@@ -25,8 +25,6 @@
+ plugin_builtins += plugin_builtin_synaptics_rmi
+
+ if get_option('tests')
+- install_data(['tests/synaptics-rmi-0x.builder.xml','tests/synaptics-rmi-10.builder.xml'],
+- install_dir: join_paths(installed_test_datadir, 'tests'))
+ env = environment()
+ env.set('G_TEST_SRCDIR', meson.current_source_dir())
+ env.set('G_TEST_BUILDDIR', meson.current_build_dir())
+@@ -41,7 +39,6 @@
+ plugin_libs,
+ plugin_builtin_synaptics_rmi,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/uefi-capsule/meson.build
++++ b/plugins/uefi-capsule/meson.build
+@@ -146,25 +146,6 @@
+ c_args: cargs
+ )
+ test('uefi-self-test', e, env: env)
+-
+-# to use these do `sudo systemctl edit fwupd.service` and set
+-# Environment="FWUPD_SYSFSFWDIR=/usr/share/installed-tests/fwupd"
+-install_data([
+- 'tests/efi/esrt/entries/entry0/capsule_flags',
+- 'tests/efi/esrt/entries/entry0/fw_class',
+- 'tests/efi/esrt/entries/entry0/fw_type',
+- 'tests/efi/esrt/entries/entry0/fw_version',
+- 'tests/efi/esrt/entries/entry0/last_attempt_status',
+- 'tests/efi/esrt/entries/entry0/last_attempt_version',
+- 'tests/efi/esrt/entries/entry0/lowest_supported_fw_version',
+- ],
+- install_dir: join_paths(installed_test_datadir, 'efi/esrt/entries/entry0'),
+-)
+-install_data([
+- 'tests/efi/efivars/CapsuleMax-39b68c46-f7fb-441b-b6ec-16b0f69821f3',
+- ],
+- install_dir: join_paths(installed_test_datadir, 'efi/efivars'),
+-)
+ endif
+
+ endif
+--- a/plugins/uefi-dbx/meson.build
++++ b/plugins/uefi-dbx/meson.build
+@@ -32,7 +32,6 @@
+ plugin_builtin_uefi_dbx,
+ ],
+ c_args: cargs,
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/uf2/meson.build
++++ b/plugins/uf2/meson.build
+@@ -18,8 +18,6 @@
+ plugin_builtins += plugin_builtin_uf2
+
+ if get_option('tests')
+- install_data(['tests/uf2.builder.xml'],
+- install_dir: join_paths(installed_test_datadir, 'tests'))
+ env = environment()
+ env.set('G_TEST_SRCDIR', meson.current_source_dir())
+ env.set('G_TEST_BUILDDIR', meson.current_build_dir())
+@@ -34,7 +32,6 @@
+ plugin_libs,
+ plugin_builtin_uf2,
+ ],
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/vli/meson.build
++++ b/plugins/vli/meson.build
+@@ -49,7 +49,6 @@
+ plugin_builtin_vli,
+ ],
+ c_args: cargs,
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/plugins/wacom-usb/meson.build
++++ b/plugins/wacom-usb/meson.build
+@@ -23,8 +23,6 @@
+ plugin_builtins += plugin_builtin_wac
+
+ if get_option('tests')
+- install_data(['tests/wacom-usb.builder.xml'],
+- install_dir: join_paths(installed_test_datadir, 'tests'))
+ env = environment()
+ env.set('G_TEST_SRCDIR', meson.current_source_dir())
+ env.set('G_TEST_BUILDDIR', meson.current_build_dir())
+@@ -40,7 +38,6 @@
+ plugin_builtin_wac,
+ ],
+ c_args: cargs,
+- install: true,
+ install_rpath: libdir_pkg,
+ install_dir: installed_test_bindir,
+ )
+--- a/src/tests/host-emulate/meson.build
++++ b/src/tests/host-emulate/meson.build
+@@ -8,7 +8,6 @@
+ output: '@0@.gz'.format(input_file),
+ capture: true,
+ command: [gzip, '-k', '--stdout', '@INPUT@'],
+- install: true,
+ install_dir: join_paths(datadir, 'fwupd', 'host-emulate.d'),
+ )
+ endforeach
diff --git a/sys-apps/fwupd/fwupd-1.8.11.ebuild b/sys-apps/fwupd/fwupd-1.8.11.ebuild
new file mode 100644
index 000000000000..ae2c0c6958c2
--- /dev/null
+++ b/sys-apps/fwupd/fwupd-1.8.11.ebuild
@@ -0,0 +1,197 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit meson python-single-r1 vala udev xdg
+
+DESCRIPTION="Aims to make updating firmware on Linux automatic, safe and reliable"
+HOMEPAGE="https://fwupd.org"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="amt archive bash-completion bluetooth cbor dell elogind fastboot flashrom gnutls gtk-doc +gusb introspection logitech lzma +man minimal modemmanager nvme policykit spi +sqlite synaptics systemd test tpm uefi"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ^^ ( elogind minimal systemd )
+ dell? ( uefi )
+ fastboot? ( gusb )
+ logitech? ( gusb )
+ minimal? ( !introspection )
+ modemmanager? ( gusb )
+ spi? ( lzma )
+ synaptics? ( gnutls )
+ test? ( archive gusb )
+ uefi? ( gnutls )
+"
+RESTRICT="!test? ( test )"
+
+BDEPEND="$(vala_depend)
+ >=dev-util/meson-0.60.0
+ virtual/pkgconfig
+ gtk-doc? (
+ $(python_gen_cond_dep '
+ >=dev-python/markdown-3.2[${PYTHON_USEDEP}]
+ ')
+ >=dev-util/gi-docgen-2021.1
+ )
+ bash-completion? ( >=app-shells/bash-completion-2.0 )
+ introspection? ( dev-libs/gobject-introspection )
+ man? (
+ app-text/docbook-sgml-utils
+ sys-apps/help2man
+ )
+ test? (
+ dev-util/umockdev
+ net-libs/gnutls[tools]
+ )
+"
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=app-arch/gcab-1.0
+ app-arch/xz-utils
+ >=dev-libs/glib-2.58:2
+ dev-libs/json-glib
+ dev-libs/libgudev:=
+ >=dev-libs/libjcat-0.1.4[gpg,pkcs7]
+ >=dev-libs/libxmlb-0.1.13:=[introspection?]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ ')
+ net-misc/curl
+ archive? ( app-arch/libarchive:= )
+ cbor? ( dev-libs/libcbor:= )
+ dell? (
+ >=app-crypt/tpm2-tss-2.0
+ >=sys-libs/libsmbios-2.4.0
+ )
+ elogind? ( >=sys-auth/elogind-211 )
+ flashrom? ( >=sys-apps/flashrom-1.2-r3 )
+ gnutls? ( net-libs/gnutls )
+ gusb? ( >=dev-libs/libgusb-0.3.5[introspection?] )
+ logitech? ( dev-libs/protobuf-c:= )
+ lzma? ( app-arch/xz-utils )
+ modemmanager? ( net-misc/modemmanager[qmi] )
+ policykit? ( >=sys-auth/polkit-0.114 )
+ sqlite? ( dev-db/sqlite )
+ systemd? ( >=sys-apps/systemd-211 )
+ tpm? ( app-crypt/tpm2-tss:= )
+ uefi? (
+ sys-apps/fwupd-efi
+ sys-boot/efibootmgr
+ sys-fs/udisks
+ sys-libs/efivar
+ )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ sys-apps/dbus
+"
+
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-libs/pango[introspection]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.11-installed_tests.patch
+)
+
+src_prepare() {
+ default
+
+ vala_setup
+
+ # c.f. https://github.com/fwupd/fwupd/issues/1414
+ sed -e "/test('thunderbolt-self-test', e, env: test_env, timeout : 120)/d" \
+ -i plugins/thunderbolt/meson.build || die
+
+ sed -e "/install_dir.*'doc'/s/doc/gtk-doc/" \
+ -i docs/meson.build || die
+
+ python_fix_shebang "${S}"/contrib/*.py
+}
+
+src_configure() {
+ local plugins=(
+ -Dplugin_gpio="enabled"
+ $(meson_feature amt plugin_intel_me)
+ $(meson_feature dell plugin_dell)
+ $(meson_feature fastboot plugin_fastboot)
+ $(meson_feature flashrom plugin_flashrom)
+ $(meson_feature gusb plugin_uf2)
+ $(meson_feature logitech plugin_logitech_bulkcontroller)
+ $(meson_feature modemmanager plugin_modem_manager)
+ $(meson_feature nvme plugin_nvme)
+ $(meson_use spi plugin_intel_spi)
+ $(meson_feature synaptics plugin_synaptics_mst)
+ $(meson_feature synaptics plugin_synaptics_rmi)
+ $(meson_feature tpm plugin_tpm)
+ $(meson_feature uefi plugin_uefi_capsule)
+ $(meson_use uefi plugin_uefi_capsule_splash)
+ $(meson_feature uefi plugin_uefi_pk)
+ )
+ if use ppc64 || use riscv ; then
+ plugins+=( -Dplugin_msr="disabled" )
+ fi
+
+ local emesonargs=(
+ --localstatedir "${EPREFIX}"/var
+ -Dbuild="$(usex minimal standalone all)"
+ -Dconsolekit="disabled"
+ -Dcurl="enabled"
+ -Defi_binary="false"
+ -Dsupported_build="enabled"
+ -Dudevdir="${EPREFIX}$(get_udevdir)"
+ $(meson_feature archive libarchive)
+ $(meson_use bash-completion bash_completion)
+ $(meson_feature bluetooth bluez)
+ $(meson_feature cbor)
+ $(meson_feature elogind)
+ $(meson_feature gnutls)
+ $(meson_feature gtk-doc docs)
+ $(meson_feature gusb)
+ $(meson_feature lzma)
+ $(meson_use man)
+ $(meson_feature introspection)
+ $(meson_feature policykit polkit)
+ $(meson_feature sqlite)
+ $(meson_feature systemd)
+ $(meson_use test tests)
+
+ ${plugins[@]}
+ )
+ use uefi && emesonargs+=( -Defi_os_dir="gentoo" )
+ export CACHE_DIRECTORY="${T}"
+ meson_src_configure
+}
+
+src_test() {
+ LC_ALL="C" meson_src_test
+}
+
+src_install() {
+ meson_src_install
+
+ if ! use minimal ; then
+ newinitd "${FILESDIR}"/${PN}-r2 ${PN}
+
+ if ! use systemd ; then
+ # Don't timeout when fwupd is running (#673140)
+ sed '/^IdleTimeout=/s@=[[:digit:]]\+@=0@' \
+ -i "${ED}"/etc/${PN}/daemon.conf || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ use minimal || udev_reload
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ use minimal || udev_reload
+}