summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2021-11-11 18:36:26 +0100
committerJonas Stein <jstein@gentoo.org>2021-11-11 18:36:26 +0100
commit3a5afebf45958d8a7708a34de55dc4f645b220dd (patch)
tree30a7e7e2de98b4e3c3383ed13a3357acfd24b91a /sys-apps
parentdev-cpp/gstreamermm: It needs to set docdir to proper path (diff)
downloadgentoo-3a5afebf45958d8a7708a34de55dc4f645b220dd.tar.gz
gentoo-3a5afebf45958d8a7708a34de55dc4f645b220dd.tar.bz2
gentoo-3a5afebf45958d8a7708a34de55dc4f645b220dd.zip
sys-apps/inxi: bump to 3.3.08.1
Version bump to 3.3.08.1 Closes: https://bugs.gentoo.org/822990 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/inxi/Manifest1
-rw-r--r--sys-apps/inxi/inxi-3.3.08.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/inxi/Manifest b/sys-apps/inxi/Manifest
index 0f855b59bff6..ebcdbc61aaf6 100644
--- a/sys-apps/inxi/Manifest
+++ b/sys-apps/inxi/Manifest
@@ -1,3 +1,4 @@
DIST inxi-3.1.06.1.tar.gz 357819 BLAKE2B e6eb8a34807323d7f46ff029af797e3a13229813bf0cff4b8b874cd21ff1d38459e2181ddf3882b4ee0d29e8c788e2fce1c01f5c295911493292082192c56c2b SHA512 6621252048e95132cfec30e341f72f5942188f273488509614aab28e55ee9987b8f3820e1298c4d9a16b4f3464f1f270fb4c1d5e5a7bf0d2f616b4180193ab6b
DIST inxi-3.3.04.1.tar.gz 450695 BLAKE2B 3bf2fc9296c9b1e2357e7df2edeb3df5069d48b401be793ab82bd630cfbf45fdc39d6403d851d46dfa9b8e7729da6dc07e96982941396e46493f4531bb29233c SHA512 0ffde2362c79a4269df0f4bbe439e50d24a13969a22f6e84f6caeb8cace2ee49fb075d6051211709efdc831c2f7ef37eaa38d70306bc8f1a86f8ed0dc7dea094
DIST inxi-3.3.06.1.tar.gz 460416 BLAKE2B a7a5eeade861294c8c18cd9594ef6fd0c681d8ae66b6e1b112dbc968be46a617db666d863f5138883d7651fad8e3b27c4f27a2b518233ffa2aae7e453feab62b SHA512 0e9d7215339235914cfcd7292443199304d44e528545a0c1c3d65d597f57da5c2678c410d215e6c8668c22677f20d62c93bbd7fee02dc74f8c9aab75b1488d00
+DIST inxi-3.3.08.1.tar.gz 467132 BLAKE2B c0254174c0a48936e1f183c16f985838cf74302da706996c1baec0c67b9c4209da5b555805cb668d626eccaa69f95e3cab2605b06d2cc7361a6cd3ff5d88c29e SHA512 bcbb81dd022dbd525ed3811406997c6689f968de8a3b6e0988381d9d2a488617ef3bc966034f9baac8eebb412b8d2e612b7cece29d65bdcb20d8b8cdeca112e6
diff --git a/sys-apps/inxi/inxi-3.3.08.1.ebuild b/sys-apps/inxi/inxi-3.3.08.1.ebuild
new file mode 100644
index 000000000000..3c22d8270f60
--- /dev/null
+++ b/sys-apps/inxi/inxi-3.3.08.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV=$(ver_rs 3 '-')
+# 2.3.56 was the last version with no tagged release.
+# It was also the last Bash based release. Later versions are Perl based
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth hddtemp opengl"
+
+RDEPEND="dev-lang/perl
+ sys-apps/pciutils
+ sys-apps/usbutils
+ bluetooth? ( net-wireless/bluez )
+ hddtemp? ( app-admin/hddtemp )
+ opengl? ( x11-apps/mesa-progs )
+ "
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc README.txt
+}