summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-05-16 14:35:14 -0700
committerPatrick McLean <chutzpah@gentoo.org>2024-05-16 14:35:34 -0700
commit5ca8c25a6abf44d015bc807419059be4f5956b9a (patch)
treea808eae71d8a746397421118c42a76842be9f299 /sys-apps
parentnet-dns/pdns-recursor: add 5.0.5 (diff)
downloadgentoo-5ca8c25a6abf44d015bc807419059be4f5956b9a.tar.gz
gentoo-5ca8c25a6abf44d015bc807419059be4f5956b9a.tar.bz2
gentoo-5ca8c25a6abf44d015bc807419059be4f5956b9a.zip
sys-apps/bolt: Add some missing test deps
Closes: https://bugs.gentoo.org/932003 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/bolt/bolt-0.9.8-r1.ebuild (renamed from sys-apps/bolt/bolt-0.9.8.ebuild)17
1 files changed, 15 insertions, 2 deletions
diff --git a/sys-apps/bolt/bolt-0.9.8.ebuild b/sys-apps/bolt/bolt-0.9.8-r1.ebuild
index d1c22d56d103..bad401eb2907 100644
--- a/sys-apps/bolt/bolt-0.9.8.ebuild
+++ b/sys-apps/bolt/bolt-0.9.8-r1.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-inherit linux-info meson udev
+PYTHON_COMPAT=( python3_1{0..2} )
+inherit linux-info python-any-r1 meson udev
DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
@@ -24,12 +25,23 @@ RDEPEND="
"
DEPEND="
${RDEPEND}
- test? ( dev-util/umockdev )
+ test? (
+ dev-util/umockdev
+ )
"
BDEPEND="
app-text/asciidoc
dev-util/glib-utils
virtual/pkgconfig
+ test? (
+ dev-util/umockdev
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep \
+ 'dev-python/pygobject[${PYTHON_USEDEP}]' \
+ 'dev-python/dbus-python[${PYTHON_USEDEP}]' \
+ 'dev-python/python-dbusmock[${PYTHON_USEDEP}]'
+ )
+ )
"
pkg_setup() {
@@ -44,6 +56,7 @@ pkg_setup() {
ERROR_HOTPLUG_PCI="Thunderbolt requires PCI hotplug support."
linux-info_pkg_setup
+ python-any-r1_pkg_setup
}
src_configure() {