summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-01 05:24:42 +0100
committerSam James <sam@gentoo.org>2023-08-01 05:24:42 +0100
commitb81b6b93e5f057ce523281756bc1a8b14e46c88d (patch)
tree1135cb18675434b45d1105d327d5c8e543eb4f7f /sys-apps
parentapp-admin/sysklogd: add 2.5.1 (diff)
downloadgentoo-b81b6b93e5f057ce523281756bc1a8b14e46c88d.tar.gz
gentoo-b81b6b93e5f057ce523281756bc1a8b14e46c88d.tar.bz2
gentoo-b81b6b93e5f057ce523281756bc1a8b14e46c88d.zip
sys-apps/pv: add 1.7.24
Bug: https://bugs.gentoo.org/911525 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pv/Manifest1
-rw-r--r--sys-apps/pv/pv-1.7.24.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/pv/Manifest b/sys-apps/pv/Manifest
index ab1f5641ff01..aab548172918 100644
--- a/sys-apps/pv/Manifest
+++ b/sys-apps/pv/Manifest
@@ -1,3 +1,4 @@
DIST pv-1.6.20.tar.bz2 115310 BLAKE2B b50623f623231e8e8615f960bad83d10e12d5274c57d23ea843d16fce30b3e690284b2d9b01f82a16b9790e2bf26f80f560e226589a62ca677a2cf90ea007691 SHA512 e445f91b298ed285ddab54a3f8a6b5d5297e2e2eb8ad7b2ee2cbacca4adda9c6ca2bf3c77bf2a93373d3875c5b3b0b345d3945cbd91fc2647c6c25f1661a6752
DIST pv-1.7.0.tar.bz2 115665 BLAKE2B efdd0434d23fe1ed008224fe0fe5182684010a78650284e920b2cd93134f08e63172df0279b8a4b2c2c4dceb9dbdaa209e402394fb1c4c431d991225f579f718 SHA512 b90ddaa1f950b1b300f1721e5ab8bc2c7a0c46491e439ce33c7b74fd4525e730a99c218a874b3dae2dc3a8a5e0eb5c5add51f7c8be48d0c3d8f135df44779af8
DIST pv-1.7.18.tar.bz2 133583 BLAKE2B b81a5d9b41e247bed5b390050678afde3611a34030b2dd76d28635d9f580f86e925c08b2a01c60126b5ac971e1dfb20ecf6562b1140bfb57ed052b0416ffc39e SHA512 4f69d1c046cae279a4e93f87b0848dfd34a9a50b8654274e1cd11dc58198e1be216451bc3af2664c336e0d231a7451dc831cc09291eb1d4f0fd0e02abc6eccea
+DIST pv-1.7.24.tar.gz 160435 BLAKE2B a6cff613ac99294d70d1347e78625d838873740d2251802b461a29de28d9c2dda8ebc1fd0a8807fc420c8faf846bc8afc7c6f3e551ff243f02fa5e9ab3caf53e SHA512 46310e2d297bef1a8a7cbf2a23b2e19b21e367902de6cf759fb1a58275e0351d1f6f1ae101a32acaaa579a16c18ed49b116e58f158c87be527533ebacabd7671
diff --git a/sys-apps/pv/pv-1.7.24.ebuild b/sys-apps/pv/pv-1.7.24.ebuild
new file mode 100644
index 000000000000..2888d46d4234
--- /dev/null
+++ b/sys-apps/pv/pv-1.7.24.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PLOCALES="de fr pl pt"
+PLOCALE_BACKUP="en"
+inherit linux-info toolchain-funcs plocale
+
+DESCRIPTION="Pipe Viewer: a tool for monitoring the progress of data through a pipe"
+HOMEPAGE="https://www.ivarch.com/programs/pv.shtml"
+SRC_URI="https://www.ivarch.com/programs/sources/${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug nls"
+
+DOCS=( README.md doc/NEWS.md doc/TODO.md )
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~SYSVIPC"
+ ERROR_SYSVIPC="You will need to enable CONFIG_SYSVIPC in your kernel to use the --remote option."
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+
+ sed -i configure -e 's|CFLAGS="-g -Wall"|:|g' || die
+
+ # These should produce the same end result (working `pv`).
+ sed -i \
+ -e 's:$(LD) $(LDFLAGS) -o:$(AR) rc:' \
+ autoconf/make/modules.mk~ || die
+
+ disable_locale() {
+ local locale=${1}
+ sed -i configure -e "/ALL_LINGUAS=/s:${locale}::g" || die
+ }
+
+ plocale_find_changes src/nls '' '.po'
+ plocale_for_each_disabled_locale disable_locale
+}
+
+src_configure() {
+ tc-export AR
+
+ econf \
+ $(use_enable debug debugging) \
+ $(use_enable nls)
+}
+
+src_test() {
+ emake -Onone check
+}