summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-09 12:12:37 +0100
committerSam James <sam@gentoo.org>2023-06-09 12:18:20 +0100
commitcd5b335d325a481ebab4893805cf4b1f0f99e28c (patch)
treebdb1a75ebc3a50d4f25aedff117104162e0eef13 /sys-apps
parentdev-util/codeblocks: drop old 20.03-r4, 20.03-r5 revisions (diff)
downloadgentoo-cd5b335d325a481ebab4893805cf4b1f0f99e28c.tar.gz
gentoo-cd5b335d325a481ebab4893805cf4b1f0f99e28c.tar.bz2
gentoo-cd5b335d325a481ebab4893805cf4b1f0f99e28c.zip
sys-apps/gentoo-functions: update for meson
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-9999.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
index d704dea16611..b43489741598 100644
--- a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
+++ b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
@@ -11,20 +11,26 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
fi
-inherit toolchain-funcs flag-o-matic
+inherit meson
DESCRIPTION="Base functions required by all Gentoo systems"
HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
LICENSE="GPL-2"
SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
# Specifically needs GNU find, as well.
RDEPEND=">=sys-apps/findutils-4.9"
src_configure() {
- tc-export CC
- append-lfs-flags
- export ROOTPREFIX="${EPREFIX}"
- export PREFIX="${EPREFIX}/usr"
+ local emesonargs=(
+ # Deliberately avoid /usr as consumers assume we're at /lib/gentoo.
+ --prefix="${EPREFIX:-/}"
+ --mandir="${EPREFIX}/usr/share/man"
+ $(meson_use test tests)
+ )
+
+ meson_src_configure
}