summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Tietz <christian.tietz@mailbox.org>2023-04-28 21:56:44 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-04-30 00:18:36 +0200
commite7b58b8d1e83ea02a2b5994735fd6e6f82e6d547 (patch)
tree40d0ad6d7ddf07653f0b4c4328243fd427fa789f /sys-apps
parentnet-misc/datapipe: EAPI8 bump, use HTTPS (diff)
downloadgentoo-e7b58b8d1e83ea02a2b5994735fd6e6f82e6d547.tar.gz
gentoo-e7b58b8d1e83ea02a2b5994735fd6e6f82e6d547.tar.bz2
gentoo-e7b58b8d1e83ea02a2b5994735fd6e6f82e6d547.zip
sys-apps/bleachbit: drop 4.4.2
Signed-off-by: Christian Tietz <christian.tietz@mailbox.org> Closes: https://github.com/gentoo/gentoo/pull/30802 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/bleachbit/bleachbit-4.4.2.ebuild86
1 files changed, 0 insertions, 86 deletions
diff --git a/sys-apps/bleachbit/bleachbit-4.4.2.ebuild b/sys-apps/bleachbit/bleachbit-4.4.2.ebuild
deleted file mode 100644
index 6ec9f9cddfc1..000000000000
--- a/sys-apps/bleachbit/bleachbit-4.4.2.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9,10} )
-PYTHON_REQ_USE="sqlite(+)"
-DISTUTILS_SINGLE_IMPL=1
-
-inherit desktop distutils-r1 virtualx
-
-DESCRIPTION="Clean junk to free disk space and to maintain privacy"
-HOMEPAGE="https://www.bleachbit.org"
-SRC_URI="https://download.bleachbit.org/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- ')
- x11-libs/gtk+:3
-"
-BDEPEND="
- sys-devel/gettext
- test? (
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]')
- )
-"
-
-distutils_enable_tests unittest
-
-# tests fail under FEATURES=usersandbox
-RESTRICT="test"
-
-python_prepare_all() {
- if use test; then
- # avoid tests requiring internet access
- rm tests/Test{Chaff,Update}.py || die
-
- # fails due to non-existent $HOME/.profile
- rm tests/TestInit.py || die
-
- # only applicable to Windows installer
- rm tests/TestNsisUtilities.py || die
-
- # these fail on upstream Travis CI as well as on Gentoo
- sed -e "s/test_notify(self)/_&/" \
- -i tests/TestGUI.py || die
-
- sed -e "s/test_get_proc_swaps(self)/_&/" \
- -i tests/TestMemory.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- emake -C po local
-}
-
-python_test() {
- virtx emake tests
-}
-
-python_install() {
- distutils-r1_python_install
- python_newscript ${PN}.py ${PN}
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- emake -C po DESTDIR="${D}" install
-
- insinto /usr/share/bleachbit/cleaners
- doins cleaners/*.xml
-
- insinto /usr/share/bleachbit
- doins data/app-menu.ui
-
- doicon ${PN}.png
- domenu org.${PN}.BleachBit.desktop
-}