summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2016-12-15 05:40:30 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2016-12-15 05:42:03 +0100
commit38b6fafecf4a802d0c7d9f6b0a6ddf4c94056220 (patch)
tree0bbfe164e34de23fc9e4ba62d61f0a8183e9eff7 /sys-auth/munge/munge-0.5.11-r1.ebuild
parentx11-libs/gdk-pixbuf: bump to 2.36.1 (diff)
downloadgentoo-38b6fafecf4a802d0c7d9f6b0a6ddf4c94056220.tar.gz
gentoo-38b6fafecf4a802d0c7d9f6b0a6ddf4c94056220.tar.bz2
gentoo-38b6fafecf4a802d0c7d9f6b0a6ddf4c94056220.zip
sys-auth/munge: fix lpe, bug 602596
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-auth/munge/munge-0.5.11-r1.ebuild')
-rw-r--r--sys-auth/munge/munge-0.5.11-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sys-auth/munge/munge-0.5.11-r1.ebuild b/sys-auth/munge/munge-0.5.11-r1.ebuild
new file mode 100644
index 000000000000..4736ded9335f
--- /dev/null
+++ b/sys-auth/munge/munge-0.5.11-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils user prefix
+
+DESCRIPTION="An authentication service for creating and validating credentials"
+HOMEPAGE="https://github.com/dun/munge"
+SRC_URI="https://github.com/dun/munge/releases/download/munge-${PV}/munge-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="gcrypt"
+
+DEPEND="app-arch/bzip2
+ sys-libs/zlib
+ gcrypt? ( dev-libs/libgcrypt:0 )
+ !gcrypt? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup munge
+ enewuser munge -1 -1 /var/lib/munge munge
+}
+
+src_prepare() {
+ # Accepted upstream, https://github.com/dun/munge/pull/40
+ epatch "${FILESDIR}"/fixed-recursive-use-of-make-in-makefiles.patch
+
+ hprefixify config/x_ac_path_openssl.m4
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir="${EPREFIX}"/var \
+ --with-crypto-lib=$(usex gcrypt libgcrypt openssl)
+}
+
+src_install() {
+ local d
+
+ default
+
+ # 450830
+ if [ -d "${ED}"/var/run ]; then
+ rm -rf "${ED}"/var/run || die
+ fi
+
+ dodir /etc/munge
+
+ for d in "init.d" "default" "sysconfig"; do
+ if [ -d "${ED}"/etc/${d} ]; then
+ rm -r "${ED}"/etc/${d} || die
+ fi
+ done
+
+ newconfd "$(prefixify_ro "${FILESDIR}"/${PN}d.confd)" ${PN}d
+ newinitd "$(prefixify_ro "${FILESDIR}"/${PN}d.initd)" ${PN}d
+}