summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-auth/pam_keystore
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-auth/pam_keystore')
-rw-r--r--sys-auth/pam_keystore/Manifest1
-rw-r--r--sys-auth/pam_keystore/metadata.xml5
-rw-r--r--sys-auth/pam_keystore/pam_keystore-0.1.3.ebuild32
3 files changed, 38 insertions, 0 deletions
diff --git a/sys-auth/pam_keystore/Manifest b/sys-auth/pam_keystore/Manifest
new file mode 100644
index 000000000000..b6d3dba20814
--- /dev/null
+++ b/sys-auth/pam_keystore/Manifest
@@ -0,0 +1 @@
+DIST pam_keystore-0.1.3.tar.bz2 5894 SHA256 edc8bafd89cc8e5a18b23ce521beaba250fcfd4a53d8c2bdab4d17b77058f493
diff --git a/sys-auth/pam_keystore/metadata.xml b/sys-auth/pam_keystore/metadata.xml
new file mode 100644
index 000000000000..81ada335fc94
--- /dev/null
+++ b/sys-auth/pam_keystore/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>pam</herd>
+</pkgmetadata>
diff --git a/sys-auth/pam_keystore/pam_keystore-0.1.3.ebuild b/sys-auth/pam_keystore/pam_keystore-0.1.3.ebuild
new file mode 100644
index 000000000000..f64c830a4551
--- /dev/null
+++ b/sys-auth/pam_keystore/pam_keystore-0.1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit pam toolchain-funcs
+
+DESCRIPTION="Keeps a login and the password the user in the kernel"
+HOMEPAGE="http://www.calculate-linux.org/main/en/pam_keystore"
+SRC_URI="ftp://ftp.calculate.ru/pub/calculate/${PN}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="virtual/pam
+ >=sys-apps/keyutils-1.1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LD_D="$(tc-getCC) -shared ${LDFLAGS}" \
+ CFLAGS="-fPIC ${CFLAGS}" \
+ SHARE= \
+ || die "make failed"
+}
+
+src_install() {
+ dopammod pam_keystore.so || die
+ newdoc README README.ru || die
+}