summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-29 07:48:51 +0000
committerSam James <sam@gentoo.org>2024-04-03 06:10:33 +0100
commit56994748ada831334531a5d22af882df730780ba (patch)
tree6d3a7b5cfc0916c7e4ca375fdb4e0e2250cfa77a /sys-block
parentdev-libs/libtommath: drop 1.2.0-r2 (diff)
downloadgentoo-56994748ada831334531a5d22af882df730780ba.tar.gz
gentoo-56994748ada831334531a5d22af882df730780ba.tar.bz2
gentoo-56994748ada831334531a5d22af882df730780ba.zip
sys-block/libzbc: fix deps
* Put gtk+ in RDEPEND too, not just DEPEND * Move pkgconfig to BDEPEND * Drop unnecessary --disable-static (default w/ EAPI 8) from econf args * Change USE=gtk -> USE=gui per QA policy Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/libzbc/libzbc-5.13.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-block/libzbc/libzbc-5.13.0-r1.ebuild b/sys-block/libzbc/libzbc-5.13.0-r1.ebuild
new file mode 100644
index 000000000000..703a3203ecc8
--- /dev/null
+++ b/sys-block/libzbc/libzbc-5.13.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A library and tools for working with ZBC and ZAC disks"
+HOMEPAGE="https://github.com/hgst/libzbc"
+SRC_URI="https://github.com/hgst/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="gui"
+
+RDEPEND="
+ gui? ( x11-libs/gtk+:3 )
+"
+DEPEND="
+ ${RDEPEND}
+ >=sys-kernel/linux-headers-4.13
+"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable gui)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}