summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-05-31 00:03:12 +0200
committerJeroen Roovers <jer@gentoo.org>2020-05-31 00:06:39 +0200
commitc8570e0a84f0342e3aad730fa09a1c2cac4a8b56 (patch)
tree7942da1b881de27e37cd9f3b2f45231319b3772a /sys-boot/palo/palo-2.14.ebuild
parentdev-libs/elfutils: use $CC in tests consistently, bug #718872 (diff)
downloadgentoo-c8570e0a84f0342e3aad730fa09a1c2cac4a8b56.tar.gz
gentoo-c8570e0a84f0342e3aad730fa09a1c2cac4a8b56.tar.bz2
gentoo-c8570e0a84f0342e3aad730fa09a1c2cac4a8b56.zip
sys-boot/palo: Version 2.14
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sys-boot/palo/palo-2.14.ebuild')
-rw-r--r--sys-boot/palo/palo-2.14.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-boot/palo/palo-2.14.ebuild b/sys-boot/palo/palo-2.14.ebuild
new file mode 100644
index 000000000000..17741656154b
--- /dev/null
+++ b/sys-boot/palo/palo-2.14.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.00-toolchain.patch
+)
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /etc/kernel/postinst.d
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+
+ doman palo.8
+
+ dodoc TODO debian/changelog README.html
+}