summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2023-03-27 19:01:45 -0400
committerKenton Groombridge <concord@gentoo.org>2023-03-27 19:01:45 -0400
commitef6ade350ae56e75c278b633bfc7551c44480d4d (patch)
tree7f1954b5de60accfb62125a9740c42df9ce4030a /sys-cluster/flux
parentnet-voip/mumble: enable py3.11 (diff)
downloadgentoo-ef6ade350ae56e75c278b633bfc7551c44480d4d.tar.gz
gentoo-ef6ade350ae56e75c278b633bfc7551c44480d4d.tar.bz2
gentoo-ef6ade350ae56e75c278b633bfc7551c44480d4d.zip
sys-cluster/flux: new package, add 0.41.2
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'sys-cluster/flux')
-rw-r--r--sys-cluster/flux/Manifest3
-rw-r--r--sys-cluster/flux/flux-0.41.2.ebuild36
-rw-r--r--sys-cluster/flux/metadata.xml11
3 files changed, 50 insertions, 0 deletions
diff --git a/sys-cluster/flux/Manifest b/sys-cluster/flux/Manifest
new file mode 100644
index 000000000000..e915741eb2f5
--- /dev/null
+++ b/sys-cluster/flux/Manifest
@@ -0,0 +1,3 @@
+DIST flux-0.41.2.tar.gz 395636 BLAKE2B 2d1732729709d0f753ff62aa5b5563b9d42f3cde42a98b5356607b640715e30afa9ebdfdb9c71281eff9188c91ea6e6b082ddc2198e4d790a76aaeb155b8ef2f SHA512 c68ad402c99b61ca9ef737749417b48dc4e852544d76311c11d94bff42c2e081a8e11e72e438cb9e1834ec7d48e69a30473aa6ab1d68c2684dde5c2b817000a2
+DIST flux2-0.41.2-deps.tar.xz 166945460 BLAKE2B 292ac5a66237916f1eeb8460f38f803fbe6bfec7cc6ee09512c0893928478049dbf8d482a897e7f4d5bed537f3cae3d73019d6c793764d1b15dc984724bc4ec7 SHA512 da36b3d78066cad548492d368df2b0d31c25a72f4fe4e5791b0c4315d5ed2625da5318b4a010395a587c072a07d23c6d6e7ff3c43bbf201dcd7d45a85dc24297
+DIST flux2-0.41.2-manifests.tar.xz 22904 BLAKE2B e23150ff1b7617f144a1250c890cb48bccbfa4547cc2d46b6d6905349c969a8505e2bc23466a469bb0eae326ec571eb5987ae5c0768b648ba6e35b1daec2b039 SHA512 ba58ffa05be150e32a30a492d28cdc582c9b0e7162b768a83ca8d44a4a08fca195700f8c124cc39cf85a0c62dfbe380304c0d203d0f05619a1b65284d22278de
diff --git a/sys-cluster/flux/flux-0.41.2.ebuild b/sys-cluster/flux/flux-0.41.2.ebuild
new file mode 100644
index 000000000000..0a791c2eca47
--- /dev/null
+++ b/sys-cluster/flux/flux-0.41.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="Flux is a tool for keeping Kubernetes clusters in sync"
+HOMEPAGE="https://fluxcd.io https://github.com/fluxcd/flux2"
+SRC_URI="https://github.com/fluxcd/flux2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~concord/distfiles/flux2-${PV}-deps.tar.xz"
+SRC_URI+=" https://dev.gentoo.org/~concord/distfiles/flux2-${PV}-manifests.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="hardened"
+
+BDEPEND=">=dev-lang/go-1.19"
+
+RESTRICT+=" test"
+S="${WORKDIR}/flux2-${PV}"
+
+src_compile() {
+ mv "${WORKDIR}"/manifests cmd/"${PN}"
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \
+ ego build -ldflags="-s -w -X main.VERSION=${PV}" -o ./bin/${PN} ./cmd/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ bin/${PN} completion bash > ${PN}.bash || die
+ bin/${PN} completion zsh > ${PN}.zsh || die
+ newbashcomp ${PN}.bash ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+}
diff --git a/sys-cluster/flux/metadata.xml b/sys-cluster/flux/metadata.xml
new file mode 100644
index 000000000000..9b9d59b7ebe0
--- /dev/null
+++ b/sys-cluster/flux/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>concord@gentoo.org</email>
+ <name>Kenton Groombridge</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fluxcd/flux2</remote-id>
+ </upstream>
+</pkgmetadata>