summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-27 00:34:17 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-27 00:37:42 +0100
commit6573b85f2753135263c241db65f2332cb26af45f (patch)
tree1ed9db620e3b19252b864bca01fc238bbd1b053a /sys-cluster/ploop
parentsys-cluster/ploop: make the patch eapply-compliant (diff)
downloadgentoo-6573b85f2753135263c241db65f2332cb26af45f.tar.gz
gentoo-6573b85f2753135263c241db65f2332cb26af45f.tar.bz2
gentoo-6573b85f2753135263c241db65f2332cb26af45f.zip
sys-cluster/ploop: update EAPI 5 -> 7
Nb. The latest version upstream is 1.15, dated April 2016. It fails to build, though. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-cluster/ploop')
-rw-r--r--sys-cluster/ploop/ploop-1.14.1-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sys-cluster/ploop/ploop-1.14.1-r1.ebuild b/sys-cluster/ploop/ploop-1.14.1-r1.ebuild
new file mode 100644
index 000000000000..5133adf338ac
--- /dev/null
+++ b/sys-cluster/ploop/ploop-1.14.1-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit tmpfiles toolchain-funcs
+
+DESCRIPTION="openvz tool and a library to control ploop block devices"
+HOMEPAGE="https://wiki.openvz.org/Download/ploop"
+SRC_URI="https://download.openvz.org/utils/ploop/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/libxml2"
+RDEPEND="${DEPEND}
+ sys-block/parted
+ sys-fs/e2fsprogs
+ sys-process/lsof
+ sys-apps/findutils"
+
+PATCHES=(
+ "${FILESDIR}"/disable_create_run_dir.patch
+)
+
+DOCS=( tools/README )
+
+src_prepare() {
+ default
+
+ # Respect CFLAGS and CC, do not add debug by default
+ sed -i \
+ -e 's|CFLAGS =|CFLAGS +=|' \
+ -e '/CFLAGS/s/-g -O0 //' \
+ -e '/CFLAGS/s/-O2//' \
+ -e 's|CC=|CC?=|' \
+ -e 's/-Werror//' \
+ -e '/DEBUG=yes/d' \
+ -e '/LOCKDIR/s/var/run/' \
+ Makefile.inc || die 'sed on Makefile.inc failed'
+ # Avoid striping of binaries
+ sed -e '/INSTALL/{s: -s::}' -i tools/Makefile || die 'sed on tools/Makefile failed'
+
+ # respect AR and RANLIB, bug #452092
+ tc-export AR RANLIB
+ sed -i -e 's/ranlib/$(RANLIB)/' lib/Makefile || die 'sed on lib/Makefile failed'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 $(usex debug 'DEBUG' '' '=yes' '')
+}
+
+src_install() {
+ default
+ rm "${ED}"/usr/$(get_libdir)/*.a || die
+}
+
+pkg_postinst() {
+ tmpfiles_process ploop.conf
+}