summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-08-09 23:20:16 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-08-09 23:24:22 -0500
commitc3aed7837d86e15663c46e24de95dd6001633693 (patch)
treea76ff78ea7032b29c3fae51a0223baaf40039709 /sys-cluster/rocm-k8s-device-plugin
parentapp-backup/dar: Stabilize 2.7.6 sparc, #864376 (diff)
downloadgentoo-c3aed7837d86e15663c46e24de95dd6001633693.tar.gz
gentoo-c3aed7837d86e15663c46e24de95dd6001633693.tar.bz2
gentoo-c3aed7837d86e15663c46e24de95dd6001633693.zip
sys-cluster/rocm-k8s-device-plugin: new package, add 0.3.0
AMD GPU device plugin for kubernetes Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster/rocm-k8s-device-plugin')
-rw-r--r--sys-cluster/rocm-k8s-device-plugin/Manifest1
-rw-r--r--sys-cluster/rocm-k8s-device-plugin/metadata.xml8
-rw-r--r--sys-cluster/rocm-k8s-device-plugin/rocm-k8s-device-plugin-0.3.0.ebuild34
3 files changed, 43 insertions, 0 deletions
diff --git a/sys-cluster/rocm-k8s-device-plugin/Manifest b/sys-cluster/rocm-k8s-device-plugin/Manifest
new file mode 100644
index 000000000000..3753aa1967a9
--- /dev/null
+++ b/sys-cluster/rocm-k8s-device-plugin/Manifest
@@ -0,0 +1 @@
+DIST rocm-k8s-device-plugin-0.3.0.tar.gz 5188051 BLAKE2B cff5a5eefea521fc398a3b9199375f8a4ed875688fc06bc6a097cdef017d1ef102eea096a8e37aa2d962afc2fc0a8153c26e36b226a31a1913ae2de97d632650 SHA512 d5c9c590aeb5fb744917662c9bc8a88a95c7b4478c614808c86ecb6caaf4f20c81a0013e6352d701c29c9c10810231ab142859ee95923e31d9267206209e4948
diff --git a/sys-cluster/rocm-k8s-device-plugin/metadata.xml b/sys-cluster/rocm-k8s-device-plugin/metadata.xml
new file mode 100644
index 000000000000..db463f3eeb66
--- /dev/null
+++ b/sys-cluster/rocm-k8s-device-plugin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-cluster/rocm-k8s-device-plugin/rocm-k8s-device-plugin-0.3.0.ebuild b/sys-cluster/rocm-k8s-device-plugin/rocm-k8s-device-plugin-0.3.0.ebuild
new file mode 100644
index 000000000000..d6426fa96bbe
--- /dev/null
+++ b/sys-cluster/rocm-k8s-device-plugin/rocm-k8s-device-plugin-0.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+# update these on every bump
+VERSION=v1.18.1-8-gabd271e
+TAG="amd-gpu-helm-${PV}"
+
+DESCRIPTION="AMD GPU device plugin for kubernetes"
+HOMEPAGE="https://github.com/RadeonOpenCompute/k8s-device-plugin"
+SRC_URI="https://github.com/RadeonOpenCompute/k8s-device-plugin/archive/${TAG}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="sys-apps/hwloc
+ x11-libs/libdrm[video_cards_amdgpu]"
+RDEPEND="${DEPEND}
+ sys-cluster/kubelet"
+
+S="${WORKDIR}/k8s-device-plugin-${TAG}"
+
+src_compile() {
+ GOBIN="${S}/bin" ego install -ldflags="-X main.gitDescribe=${VERSION}" \
+ ./cmd/k8s-device-plugin
+}
+
+src_install() {
+ exeinto /var/lib/kubelet/device-plugins
+ doexe bin/k8s-device-plugin
+ einstalldocs
+}