summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 12:21:38 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 12:53:17 +0100
commit202d1183c1302539e4fc06635d1c8b8df733b6b9 (patch)
tree67402a382bf205eb8c81e8fc1de3aaaec5235803 /sys-devel/clang-toolchain-symlinks
parentMove {sys-devel → llvm-core}/clang-runtime (diff)
downloadgentoo-202d1183c1302539e4fc06635d1c8b8df733b6b9.tar.gz
gentoo-202d1183c1302539e4fc06635d1c8b8df733b6b9.tar.bz2
gentoo-202d1183c1302539e4fc06635d1c8b8df733b6b9.zip
Move {sys-devel → llvm-core}/clang-toolchain-symlinks
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-toolchain-symlinks')
-rw-r--r--sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-15-r2.ebuild59
-rw-r--r--sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-16-r2.ebuild59
-rw-r--r--sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-17.ebuild59
-rw-r--r--sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-18.ebuild59
-rw-r--r--sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-19.ebuild59
-rw-r--r--sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-20.ebuild58
-rw-r--r--sys-devel/clang-toolchain-symlinks/metadata.xml26
7 files changed, 0 insertions, 379 deletions
diff --git a/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-15-r2.ebuild b/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-15-r2.ebuild
deleted file mode 100644
index 988214f580c9..000000000000
--- a/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-15-r2.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib
-
-DESCRIPTION="Symlinks to use Clang on GCC-free system"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
-S=${WORKDIR}
-
-LICENSE="public-domain"
-SLOT="${PV}"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x64-macos"
-IUSE="gcc-symlinks multilib-symlinks +native-symlinks"
-
-# Blocker for bug #872416
-RDEPEND="
- !<sys-devel/gcc-config-2.6
- sys-devel/clang:${SLOT}
-"
-
-src_install() {
- local tools=()
-
- if use native-symlinks; then
- tools+=(
- cc:clang
- cpp:clang-cpp
- c++:clang++
- )
- fi
- if use gcc-symlinks; then
- tools+=(
- gcc:clang
- g++:clang++
- )
- fi
-
- local chosts=( "${CHOST}" )
- if use multilib-symlinks; then
- local abi
- for abi in $(get_all_abis); do
- chosts+=( "$(get_abi_CHOST "${abi}")" )
- done
- fi
-
- local chost t
- local dest=/usr/lib/llvm/${SLOT}/bin
- dodir "${dest}"
- for t in "${tools[@]}"; do
- dosym "${t#*:}" "${dest}/${t%:*}"
- done
- for chost in "${chosts[@]}"; do
- for t in "${tools[@]}"; do
- dosym "${t#*:}" "${dest}/${chost}-${t%:*}"
- done
- done
-}
diff --git a/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-16-r2.ebuild b/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-16-r2.ebuild
deleted file mode 100644
index 436e2673639f..000000000000
--- a/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-16-r2.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib
-
-DESCRIPTION="Symlinks to use Clang on GCC-free system"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
-S=${WORKDIR}
-
-LICENSE="public-domain"
-SLOT="${PV}"
-KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~arm64-macos ~x64-macos"
-IUSE="gcc-symlinks multilib-symlinks +native-symlinks"
-
-# Blocker for bug #872416
-RDEPEND="
- !<sys-devel/gcc-config-2.6
- sys-devel/clang:${SLOT}
-"
-
-src_install() {
- local tools=()
-
- if use native-symlinks; then
- tools+=(
- cc:clang
- cpp:clang-cpp
- c++:clang++
- )
- fi
- if use gcc-symlinks; then
- tools+=(
- gcc:clang
- g++:clang++
- )
- fi
-
- local chosts=( "${CHOST}" )
- if use multilib-symlinks; then
- local abi
- for abi in $(get_all_abis); do
- chosts+=( "$(get_abi_CHOST "${abi}")" )
- done
- fi
-
- local chost t
- local dest=/usr/lib/llvm/${SLOT}/bin
- dodir "${dest}"
- for t in "${tools[@]}"; do
- dosym "${t#*:}" "${dest}/${t%:*}"
- done
- for chost in "${chosts[@]}"; do
- for t in "${tools[@]}"; do
- dosym "${t#*:}" "${dest}/${chost}-${t%:*}"
- done
- done
-}
diff --git a/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-17.ebuild b/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-17.ebuild
deleted file mode 100644
index 436e2673639f..000000000000
--- a/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-17.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib
-
-DESCRIPTION="Symlinks to use Clang on GCC-free system"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
-S=${WORKDIR}
-
-LICENSE="public-domain"
-SLOT="${PV}"
-KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~arm64-macos ~x64-macos"
-IUSE="gcc-symlinks multilib-symlinks +native-symlinks"
-
-# Blocker for bug #872416
-RDEPEND="
- !<sys-devel/gcc-config-2.6
- sys-devel/clang:${SLOT}
-"
-
-src_install() {
- local tools=()
-
- if use native-symlinks; then
- tools+=(
- cc:clang
- cpp:clang-cpp
- c++:clang++
- )
- fi
- if use gcc-symlinks; then
- tools+=(
- gcc:clang
- g++:clang++
- )
- fi
-
- local chosts=( "${CHOST}" )
- if use multilib-symlinks; then
- local abi
- for abi in $(get_all_abis); do
- chosts+=( "$(get_abi_CHOST "${abi}")" )
- done
- fi
-
- local chost t
- local dest=/usr/lib/llvm/${SLOT}/bin
- dodir "${dest}"
- for t in "${tools[@]}"; do
- dosym "${t#*:}" "${dest}/${t%:*}"
- done
- for chost in "${chosts[@]}"; do
- for t in "${tools[@]}"; do
- dosym "${t#*:}" "${dest}/${chost}-${t%:*}"
- done
- done
-}
diff --git a/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-18.ebuild b/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-18.ebuild
deleted file mode 100644
index 18d3e444c0e2..000000000000
--- a/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-18.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib
-
-DESCRIPTION="Symlinks to use Clang on GCC-free system"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
-S=${WORKDIR}
-
-LICENSE="public-domain"
-SLOT="${PV}"
-KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~arm64-macos ~x64-macos"
-IUSE="gcc-symlinks multilib-symlinks +native-symlinks"
-
-# Blocker for bug #872416
-RDEPEND="
- !<sys-devel/gcc-config-2.6
- sys-devel/clang:${SLOT}
-"
-
-src_install() {
- local tools=()
-
- if use native-symlinks; then
- tools+=(
- cc:clang
- cpp:clang-cpp
- c++:clang++
- )
- fi
- if use gcc-symlinks; then
- tools+=(
- gcc:clang
- g++:clang++
- )
- fi
-
- local chosts=( "${CHOST}" )
- if use multilib-symlinks; then
- local abi
- for abi in $(get_all_abis); do
- chosts+=( "$(get_abi_CHOST "${abi}")" )
- done
- fi
-
- local chost t
- local dest=/usr/lib/llvm/${SLOT}/bin
- dodir "${dest}"
- for t in "${tools[@]}"; do
- dosym "${t#*:}" "${dest}/${t%:*}"
- done
- for chost in "${chosts[@]}"; do
- for t in "${tools[@]}"; do
- dosym "${t#*:}" "${dest}/${chost}-${t%:*}"
- done
- done
-}
diff --git a/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-19.ebuild b/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-19.ebuild
deleted file mode 100644
index 18d3e444c0e2..000000000000
--- a/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-19.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib
-
-DESCRIPTION="Symlinks to use Clang on GCC-free system"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
-S=${WORKDIR}
-
-LICENSE="public-domain"
-SLOT="${PV}"
-KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~arm64-macos ~x64-macos"
-IUSE="gcc-symlinks multilib-symlinks +native-symlinks"
-
-# Blocker for bug #872416
-RDEPEND="
- !<sys-devel/gcc-config-2.6
- sys-devel/clang:${SLOT}
-"
-
-src_install() {
- local tools=()
-
- if use native-symlinks; then
- tools+=(
- cc:clang
- cpp:clang-cpp
- c++:clang++
- )
- fi
- if use gcc-symlinks; then
- tools+=(
- gcc:clang
- g++:clang++
- )
- fi
-
- local chosts=( "${CHOST}" )
- if use multilib-symlinks; then
- local abi
- for abi in $(get_all_abis); do
- chosts+=( "$(get_abi_CHOST "${abi}")" )
- done
- fi
-
- local chost t
- local dest=/usr/lib/llvm/${SLOT}/bin
- dodir "${dest}"
- for t in "${tools[@]}"; do
- dosym "${t#*:}" "${dest}/${t%:*}"
- done
- for chost in "${chosts[@]}"; do
- for t in "${tools[@]}"; do
- dosym "${t#*:}" "${dest}/${chost}-${t%:*}"
- done
- done
-}
diff --git a/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-20.ebuild b/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-20.ebuild
deleted file mode 100644
index 3496a0f89b67..000000000000
--- a/sys-devel/clang-toolchain-symlinks/clang-toolchain-symlinks-20.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib
-
-DESCRIPTION="Symlinks to use Clang on GCC-free system"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
-S=${WORKDIR}
-
-LICENSE="public-domain"
-SLOT="${PV}"
-IUSE="gcc-symlinks multilib-symlinks +native-symlinks"
-
-# Blocker for bug #872416
-RDEPEND="
- !<sys-devel/gcc-config-2.6
- sys-devel/clang:${SLOT}
-"
-
-src_install() {
- local tools=()
-
- if use native-symlinks; then
- tools+=(
- cc:clang
- cpp:clang-cpp
- c++:clang++
- )
- fi
- if use gcc-symlinks; then
- tools+=(
- gcc:clang
- g++:clang++
- )
- fi
-
- local chosts=( "${CHOST}" )
- if use multilib-symlinks; then
- local abi
- for abi in $(get_all_abis); do
- chosts+=( "$(get_abi_CHOST "${abi}")" )
- done
- fi
-
- local chost t
- local dest=/usr/lib/llvm/${SLOT}/bin
- dodir "${dest}"
- for t in "${tools[@]}"; do
- dosym "${t#*:}" "${dest}/${t%:*}"
- done
- for chost in "${chosts[@]}"; do
- for t in "${tools[@]}"; do
- dosym "${t#*:}" "${dest}/${chost}-${t%:*}"
- done
- done
-}
diff --git a/sys-devel/clang-toolchain-symlinks/metadata.xml b/sys-devel/clang-toolchain-symlinks/metadata.xml
deleted file mode 100644
index bf4e9fc6a6ca..000000000000
--- a/sys-devel/clang-toolchain-symlinks/metadata.xml
+++ /dev/null
@@ -1,26 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>llvm@gentoo.org</email>
- </maintainer>
- <use>
- <flag name="gcc-symlinks">
- Install symlinks for 'gcc' and 'g++' for extra
- compatibility.
- </flag>
- <flag name="multilib-symlinks">
- Install symlinks for all ABI CHOSTs. Note that this can
- result in gcc being overrode for native builds, as well
- as conflict with crossdev if used for the same targets.
- </flag>
- <flag name="native-symlinks">
- Install generic tool symlinks like 'cc' and 'c++',
- as well as ${CTARGET}-*. These symlinks are installed
- into slotted LLVM bindir, so they should not take precedence
- over symlinks installed into /usr/bin
- by <pkg>sys-devel/gcc-config</pkg> but they can be helpful
- for GCC-free setups.
- </flag>
- </use>
-</pkgmetadata>