summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-08 23:00:46 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-08 23:18:54 +0100
commitac86f623016f2232dc6b645ee70c747b05e2a1cf (patch)
tree5914a2b4ee3b29cb6127f280efa7cadbcd73fb3d /sys-devel/clang
parentsys-devel/lld: Control lit job count (diff)
downloadgentoo-ac86f623016f2232dc6b645ee70c747b05e2a1cf.tar.gz
gentoo-ac86f623016f2232dc6b645ee70c747b05e2a1cf.tar.bz2
gentoo-ac86f623016f2232dc6b645ee70c747b05e2a1cf.zip
sys-devel/clang: Control lit job count
Closes: https://bugs.gentoo.org/649554
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/clang-6.0.9999.ebuild5
-rw-r--r--sys-devel/clang/clang-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/sys-devel/clang/clang-6.0.9999.ebuild b/sys-devel/clang/clang-6.0.9999.ebuild
index 2a2a844387a9..245213c78d2e 100644
--- a/sys-devel/clang/clang-6.0.9999.ebuild
+++ b/sys-devel/clang/clang-6.0.9999.ebuild
@@ -9,7 +9,8 @@ CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
inherit cmake-utils eapi7-ver flag-o-matic git-r3 llvm \
- multilib-minimal pax-utils python-single-r1 toolchain-funcs
+ multilib-minimal multiprocessing pax-utils python-single-r1 \
+ toolchain-funcs
DESCRIPTION="C language family frontend for LLVM"
HOMEPAGE="https://llvm.org/"
@@ -136,7 +137,7 @@ multilib_src_configure() {
)
use test && mycmakeargs+=(
-DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
- -DLLVM_LIT_ARGS="-vv"
+ -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
)
if multilib_is_native_abi; then
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index b3392999ee87..9513fa282b5b 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -9,7 +9,8 @@ CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
inherit cmake-utils eapi7-ver flag-o-matic git-r3 llvm \
- multilib-minimal pax-utils python-single-r1 toolchain-funcs
+ multilib-minimal multiprocessing pax-utils python-single-r1 \
+ toolchain-funcs
DESCRIPTION="C language family frontend for LLVM"
HOMEPAGE="https://llvm.org/"
@@ -137,7 +138,7 @@ multilib_src_configure() {
)
use test && mycmakeargs+=(
-DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
- -DLLVM_LIT_ARGS="-vv"
+ -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
)
if multilib_is_native_abi; then