summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-18 03:16:17 +0100
committerSam James <sam@gentoo.org>2024-09-18 03:45:33 +0100
commitea3cc27f4c69cb50afd5f6786e6c56d709f48c20 (patch)
tree04b3e075070a418e1feaaf2e7fd60c1abec060f6 /sys-devel/mold/mold-9999.ebuild
parentsys-devel/mold: fix --icf assert (diff)
downloadgentoo-ea3cc27f4c69cb50afd5f6786e6c56d709f48c20.tar.gz
gentoo-ea3cc27f4c69cb50afd5f6786e6c56d709f48c20.tar.bz2
gentoo-ea3cc27f4c69cb50afd5f6786e6c56d709f48c20.zip
sys-devel/mold: control assertions with USE=debug
Still not really sure how we should handle this distro-wide but whatever. Anyway, the assertions being enabled is how we hit #938009. Bug: https://bugs.gentoo.org/938009 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/mold/mold-9999.ebuild')
-rw-r--r--sys-devel/mold/mold-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-devel/mold/mold-9999.ebuild b/sys-devel/mold/mold-9999.ebuild
index d13290655de3..53b3beaf330c 100644
--- a/sys-devel/mold/mold-9999.ebuild
+++ b/sys-devel/mold/mold-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake toolchain-funcs
+inherit cmake flag-o-matic toolchain-funcs
DESCRIPTION="A Modern Linker"
HOMEPAGE="https://github.com/rui314/mold"
@@ -12,7 +12,7 @@ if [[ ${PV} == 9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/rui314/mold/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~sparc ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~riscv ~sparc ~x86"
fi
# mold (MIT)
@@ -20,6 +20,7 @@ fi
# - siphash ( MIT CC0-1.0 )
LICENSE="MIT BSD-2 CC0-1.0"
SLOT="0"
+IUSE="debug"
RDEPEND="
app-arch/zstd:=
@@ -65,6 +66,8 @@ src_prepare() {
}
src_configure() {
+ use debug || append-cppflags "-DNDEBUG"
+
local mycmakeargs=(
-DMOLD_ENABLE_QEMU_TESTS=OFF
-DMOLD_LTO=OFF # Should be up to the user to decide this with CXXFLAGS.