summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-01 02:36:21 +0100
committerSam James <sam@gentoo.org>2024-09-01 02:36:21 +0100
commite4943ae98f128639daa719235195e2a8601c3b3b (patch)
tree370aceb819f3bdb0f8c74d1b054d3cff8661226d /sys-devel/patch
parentsys-auth/polkit: add 9999-r1 (diff)
downloadgentoo-e4943ae98f128639daa719235195e2a8601c3b3b.tar.gz
gentoo-e4943ae98f128639daa719235195e2a8601c3b3b.tar.bz2
gentoo-e4943ae98f128639daa719235195e2a8601c3b3b.zip
sys-devel/patch: add 9999
patch is getting a lot of changes in preparation for a new release so let's make it easy to test. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/patch')
-rw-r--r--sys-devel/patch/patch-2.7.6-r5.ebuild37
-rw-r--r--sys-devel/patch/patch-9999.ebuild69
2 files changed, 100 insertions, 6 deletions
diff --git a/sys-devel/patch/patch-2.7.6-r5.ebuild b/sys-devel/patch/patch-2.7.6-r5.ebuild
index e1dfc88fa933..0456b44dd8c6 100644
--- a/sys-devel/patch/patch-2.7.6-r5.ebuild
+++ b/sys-devel/patch/patch-2.7.6-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,19 +8,27 @@ inherit flag-o-matic verify-sig
DESCRIPTION="Utility to apply diffs to files"
HOMEPAGE="https://www.gnu.org/software/patch/patch.html"
-SRC_URI="mirror://gnu/patch/${P}.tar.xz"
-SRC_URI+=" verify-sig? ( mirror://gnu/patch/${P}.tar.xz.sig )"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/patch.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://gnu/patch/${P}.tar.xz"
+ SRC_URI+=" verify-sig? ( mirror://gnu/patch/${P}.tar.xz.sig )"
+
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="static test xattr"
RESTRICT="!test? ( test )"
RDEPEND="xattr? ( sys-apps/attr )"
DEPEND="${RDEPEND}"
-BDEPEND="test? ( sys-apps/ed )
- verify-sig? ( sec-keys/openpgp-keys-patch )"
+BDEPEND="
+ test? ( sys-apps/ed )
+ verify-sig? ( sec-keys/openpgp-keys-patch )
+"
PATCHES=(
"${FILESDIR}"/${P}-fix-test-suite.patch
@@ -37,6 +45,19 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.7.6-Avoid-invalid-memory-access-in-context-format-diffs.patch
)
+src_unpack() {
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+
+ cd "${S}" || die
+ ./bootstrap || die
+ elif use verify-sig ; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ fi
+
+ default
+}
+
src_configure() {
use static && append-ldflags -static
@@ -50,6 +71,10 @@ src_configure() {
econf "${myeconfargs[@]}"
}
+src_test() {
+ emake check gl_public_submodule_commit=
+}
+
src_install() {
default
diff --git a/sys-devel/patch/patch-9999.ebuild b/sys-devel/patch/patch-9999.ebuild
new file mode 100644
index 000000000000..c8ff9cf8be70
--- /dev/null
+++ b/sys-devel/patch/patch-9999.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/patch.asc
+inherit flag-o-matic verify-sig
+
+DESCRIPTION="Utility to apply diffs to files"
+HOMEPAGE="https://www.gnu.org/software/patch/patch.html"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/patch.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://gnu/patch/${P}.tar.xz"
+ SRC_URI+=" verify-sig? ( mirror://gnu/patch/${P}.tar.xz.sig )"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="static test xattr"
+RESTRICT="!test? ( test )"
+
+RDEPEND="xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? ( sys-apps/ed )
+ verify-sig? ( sec-keys/openpgp-keys-patch )
+"
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+
+ cd "${S}" || die
+ ./bootstrap || die
+ elif use verify-sig ; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ fi
+
+ default
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ local myeconfargs=(
+ $(use_enable xattr)
+ # rename to gpatch for better BSD compatibility
+ --program-prefix=g
+ )
+ # Do not let $ED mess up the search for `ed` 470210.
+ ac_cv_path_ED=$(type -P ed) \
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake check gl_public_submodule_commit=
+}
+
+src_install() {
+ default
+
+ # symlink to the standard name
+ dosym gpatch /usr/bin/patch
+ dosym gpatch.1 /usr/share/man/man1/patch.1
+}