summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-08-20 19:48:54 +0300
committerSam James <sam@gentoo.org>2023-08-21 07:14:39 +0100
commit3950a8423a88641745ec996ee15a02e2e298ef94 (patch)
treed2075102c682d380e5898f8530906be0350d7f22 /sys-devel
parentnet-misc/r8125: Stabilize 9.011.01-r1 x86, #912390 (diff)
downloadgentoo-3950a8423a88641745ec996ee15a02e2e298ef94.tar.gz
gentoo-3950a8423a88641745ec996ee15a02e2e298ef94.tar.bz2
gentoo-3950a8423a88641745ec996ee15a02e2e298ef94.zip
sys-devel/clang-common: Install config files for all supported ABIs
Closes: https://bugs.gentoo.org/912685 Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/32395 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0.9999.ebuild22
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0_rc2-r2.ebuild (renamed from sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild)22
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0.9999.ebuild22
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0_pre20230803-r1.ebuild (renamed from sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild)22
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0_pre20230810-r2.ebuild (renamed from sys-devel/clang-common/clang-common-18.0.0_pre20230810-r1.ebuild)22
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0_pre20230820-r1.ebuild (renamed from sys-devel/clang-common/clang-common-18.0.0_pre20230820.ebuild)22
6 files changed, 84 insertions, 48 deletions
diff --git a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
index aed6e024eff7..abf3150abbd6 100644
--- a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit bash-completion-r1 llvm.org
+inherit bash-completion-r1 llvm.org multilib
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
@@ -169,15 +169,21 @@ src_install() {
EOF
fi
- # We only install config files for ${CHOST} because unprefixed tools
+ # We only install config files for supported ABIs because unprefixed tools
# might be used for crosscompilation where e.g. PIE may not be supported.
# See bug #912237 and bug #901247.
- local tool
- for tool in ${CHOST}-clang{,++,-cpp}; do
- newins - "${tool}.cfg" <<-EOF
- # This configuration file is used by ${tool} driver.
- @gentoo-common.cfg
- EOF
+ # Just ${CHOST} won't do due to bug #912685.
+ local abi
+ for abi in $(get_all_abis); do
+ local abi_chost=$(get_abi_CHOST "${abi}")
+
+ local tool
+ for tool in ${abi_chost}-clang{,++,-cpp}; do
+ newins - "${tool}.cfg" <<-EOF
+ # This configuration file is used by ${tool} driver.
+ @gentoo-common.cfg
+ EOF
+ done
done
}
diff --git a/sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild b/sys-devel/clang-common/clang-common-17.0.0_rc2-r2.ebuild
index aed6e024eff7..abf3150abbd6 100644
--- a/sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0_rc2-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit bash-completion-r1 llvm.org
+inherit bash-completion-r1 llvm.org multilib
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
@@ -169,15 +169,21 @@ src_install() {
EOF
fi
- # We only install config files for ${CHOST} because unprefixed tools
+ # We only install config files for supported ABIs because unprefixed tools
# might be used for crosscompilation where e.g. PIE may not be supported.
# See bug #912237 and bug #901247.
- local tool
- for tool in ${CHOST}-clang{,++,-cpp}; do
- newins - "${tool}.cfg" <<-EOF
- # This configuration file is used by ${tool} driver.
- @gentoo-common.cfg
- EOF
+ # Just ${CHOST} won't do due to bug #912685.
+ local abi
+ for abi in $(get_all_abis); do
+ local abi_chost=$(get_abi_CHOST "${abi}")
+
+ local tool
+ for tool in ${abi_chost}-clang{,++,-cpp}; do
+ newins - "${tool}.cfg" <<-EOF
+ # This configuration file is used by ${tool} driver.
+ @gentoo-common.cfg
+ EOF
+ done
done
}
diff --git a/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
index aed6e024eff7..abf3150abbd6 100644
--- a/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit bash-completion-r1 llvm.org
+inherit bash-completion-r1 llvm.org multilib
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
@@ -169,15 +169,21 @@ src_install() {
EOF
fi
- # We only install config files for ${CHOST} because unprefixed tools
+ # We only install config files for supported ABIs because unprefixed tools
# might be used for crosscompilation where e.g. PIE may not be supported.
# See bug #912237 and bug #901247.
- local tool
- for tool in ${CHOST}-clang{,++,-cpp}; do
- newins - "${tool}.cfg" <<-EOF
- # This configuration file is used by ${tool} driver.
- @gentoo-common.cfg
- EOF
+ # Just ${CHOST} won't do due to bug #912685.
+ local abi
+ for abi in $(get_all_abis); do
+ local abi_chost=$(get_abi_CHOST "${abi}")
+
+ local tool
+ for tool in ${abi_chost}-clang{,++,-cpp}; do
+ newins - "${tool}.cfg" <<-EOF
+ # This configuration file is used by ${tool} driver.
+ @gentoo-common.cfg
+ EOF
+ done
done
}
diff --git a/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild b/sys-devel/clang-common/clang-common-18.0.0_pre20230803-r1.ebuild
index aed6e024eff7..abf3150abbd6 100644
--- a/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0_pre20230803-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit bash-completion-r1 llvm.org
+inherit bash-completion-r1 llvm.org multilib
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
@@ -169,15 +169,21 @@ src_install() {
EOF
fi
- # We only install config files for ${CHOST} because unprefixed tools
+ # We only install config files for supported ABIs because unprefixed tools
# might be used for crosscompilation where e.g. PIE may not be supported.
# See bug #912237 and bug #901247.
- local tool
- for tool in ${CHOST}-clang{,++,-cpp}; do
- newins - "${tool}.cfg" <<-EOF
- # This configuration file is used by ${tool} driver.
- @gentoo-common.cfg
- EOF
+ # Just ${CHOST} won't do due to bug #912685.
+ local abi
+ for abi in $(get_all_abis); do
+ local abi_chost=$(get_abi_CHOST "${abi}")
+
+ local tool
+ for tool in ${abi_chost}-clang{,++,-cpp}; do
+ newins - "${tool}.cfg" <<-EOF
+ # This configuration file is used by ${tool} driver.
+ @gentoo-common.cfg
+ EOF
+ done
done
}
diff --git a/sys-devel/clang-common/clang-common-18.0.0_pre20230810-r1.ebuild b/sys-devel/clang-common/clang-common-18.0.0_pre20230810-r2.ebuild
index aed6e024eff7..abf3150abbd6 100644
--- a/sys-devel/clang-common/clang-common-18.0.0_pre20230810-r1.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0_pre20230810-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit bash-completion-r1 llvm.org
+inherit bash-completion-r1 llvm.org multilib
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
@@ -169,15 +169,21 @@ src_install() {
EOF
fi
- # We only install config files for ${CHOST} because unprefixed tools
+ # We only install config files for supported ABIs because unprefixed tools
# might be used for crosscompilation where e.g. PIE may not be supported.
# See bug #912237 and bug #901247.
- local tool
- for tool in ${CHOST}-clang{,++,-cpp}; do
- newins - "${tool}.cfg" <<-EOF
- # This configuration file is used by ${tool} driver.
- @gentoo-common.cfg
- EOF
+ # Just ${CHOST} won't do due to bug #912685.
+ local abi
+ for abi in $(get_all_abis); do
+ local abi_chost=$(get_abi_CHOST "${abi}")
+
+ local tool
+ for tool in ${abi_chost}-clang{,++,-cpp}; do
+ newins - "${tool}.cfg" <<-EOF
+ # This configuration file is used by ${tool} driver.
+ @gentoo-common.cfg
+ EOF
+ done
done
}
diff --git a/sys-devel/clang-common/clang-common-18.0.0_pre20230820.ebuild b/sys-devel/clang-common/clang-common-18.0.0_pre20230820-r1.ebuild
index aed6e024eff7..abf3150abbd6 100644
--- a/sys-devel/clang-common/clang-common-18.0.0_pre20230820.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0_pre20230820-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit bash-completion-r1 llvm.org
+inherit bash-completion-r1 llvm.org multilib
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
@@ -169,15 +169,21 @@ src_install() {
EOF
fi
- # We only install config files for ${CHOST} because unprefixed tools
+ # We only install config files for supported ABIs because unprefixed tools
# might be used for crosscompilation where e.g. PIE may not be supported.
# See bug #912237 and bug #901247.
- local tool
- for tool in ${CHOST}-clang{,++,-cpp}; do
- newins - "${tool}.cfg" <<-EOF
- # This configuration file is used by ${tool} driver.
- @gentoo-common.cfg
- EOF
+ # Just ${CHOST} won't do due to bug #912685.
+ local abi
+ for abi in $(get_all_abis); do
+ local abi_chost=$(get_abi_CHOST "${abi}")
+
+ local tool
+ for tool in ${abi_chost}-clang{,++,-cpp}; do
+ newins - "${tool}.cfg" <<-EOF
+ # This configuration file is used by ${tool} driver.
+ @gentoo-common.cfg
+ EOF
+ done
done
}