summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-02-25 09:18:48 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-02-25 09:18:54 +0000
commit4bbd96b2a5e8ca66775082c6dc238ab216a3ac0a (patch)
tree5e647a14db270b97c3b715a7694aef7efb841912 /sys-devel
parentx11-misc/wmctrl: set BDEPEND + trivial cleanups (diff)
downloadgentoo-4bbd96b2a5e8ca66775082c6dc238ab216a3ac0a.tar.gz
gentoo-4bbd96b2a5e8ca66775082c6dc238ab216a3ac0a.tar.bz2
gentoo-4bbd96b2a5e8ca66775082c6dc238ab216a3ac0a.zip
sys-devel/sparse: bump up to 0.6.3
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/sparse/Manifest1
-rw-r--r--sys-devel/sparse/sparse-0.6.3.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-devel/sparse/Manifest b/sys-devel/sparse/Manifest
index e026163b79b0..5539731c02c7 100644
--- a/sys-devel/sparse/Manifest
+++ b/sys-devel/sparse/Manifest
@@ -1 +1,2 @@
DIST sparse-0.6.2.tar.xz 340100 BLAKE2B 72463fe93753f2cdced3411d1ccb18cc30dce82c4f6ae6289cf4297c66cee9f52ba96f96cceac1f134b017a7d6691b019c2f22cc801522e7a0fe0c5e0b4c8da4 SHA512 43c16b5cb4141077dd51f93e877e28e1a00e69ced58a9c8f643635b6f87a8044cddfe29a734b4a43282748e12f287b19b4fb3ce8c5e0b13931a3355974dff982
+DIST sparse-0.6.3.tar.xz 350676 BLAKE2B 5c8f54f3b7d2095df30b9a59a151e307ebedac5dbb6910ab5684b298c2b427e55dd43697e698fd289fb0d8e824ba4d72c2761772babb9f438e622f439ab3448d SHA512 33170065ea5967d7c640a7551acc78d7efee9f7aa6a9edf6afe2cdd8a04ea5cebe7b5dcdeebf791d384542b8bcdd4e818c75e7ae2e7aa4e1edbd56b68367b28f
diff --git a/sys-devel/sparse/sparse-0.6.3.ebuild b/sys-devel/sparse/sparse-0.6.3.ebuild
new file mode 100644
index 000000000000..34da20a600a3
--- /dev/null
+++ b/sys-devel/sparse/sparse-0.6.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils llvm multilib toolchain-funcs
+
+DESCRIPTION="C semantic parser"
+HOMEPAGE="https://sparse.wiki.kernel.org/index.php/Main_Page"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/devel/${PN}/${PN}.git"
+else
+ SRC_URI="https://www.kernel.org/pub/software/devel/${PN}/dist/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="gtk llvm sqlite test xml"
+RESTRICT="!test? ( test )"
+
+LLVM_MAX_SLOT=10
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
+ llvm? ( sys-devel/llvm:${LLVM_MAX_SLOT}= )
+ sqlite? ( dev-db/sqlite:= )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ gtk? ( virtual/pkgconfig )
+ xml? ( virtual/pkgconfig )"
+
+pkg_setup() {
+ use llvm && llvm_pkg_setup
+}
+
+_emake() {
+ # Makefile does not allow for an easy override of flags.
+ # Collect them here and override default phases.
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ CFLAGS="${CFLAGS}" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ \
+ HAVE_GTK=$(usex gtk) \
+ HAVE_LLVM=$(usex llvm) \
+ HAVE_SQLITE=$(usex sqlite) \
+ HAVE_LIBXML=$(usex xml) \
+ \
+ V=1 \
+ PREFIX="${EPREFIX}/usr" \
+ \
+ "$@"
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake check
+}
+
+src_install() {
+ _emake DESTDIR="${D}" install
+
+ dodoc FAQ README
+}