summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-28 20:54:45 +0100
committerSam James <sam@gentoo.org>2022-04-28 21:01:42 +0100
commit4ce6587b573904d6b9df6a477b46fda27b82a9b1 (patch)
treea91040c525ec76b378fa9aced4c07927e970b963 /sys-devel
parentdev-python/elementpath: Bump to 2.5.1 (diff)
downloadgentoo-4ce6587b573904d6b9df6a477b46fda27b82a9b1.tar.gz
gentoo-4ce6587b573904d6b9df6a477b46fda27b82a9b1.tar.bz2
gentoo-4ce6587b573904d6b9df6a477b46fda27b82a9b1.zip
sys-devel/gcc: add 13.0.0_pre9999; update 12.0.0_pre9999 for release branch
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-12.0.0_pre9999.ebuild2
-rw-r--r--sys-devel/gcc/gcc-13.0.0_pre9999.ebuild38
2 files changed, 39 insertions, 1 deletions
diff --git a/sys-devel/gcc/gcc-12.0.0_pre9999.ebuild b/sys-devel/gcc/gcc-12.0.0_pre9999.ebuild
index 5874fa468001..c1e18287bd3f 100644
--- a/sys-devel/gcc/gcc-12.0.0_pre9999.ebuild
+++ b/sys-devel/gcc/gcc-12.0.0_pre9999.ebuild
@@ -12,7 +12,7 @@ MUSL_GCC_VER="12.0.0"
inherit toolchain
# Needs to be after inherit (for now?), bug #830908
-EGIT_BRANCH=master
+EGIT_BRANCH=releases/gcc-12
# Don't keyword live ebuilds
#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
diff --git a/sys-devel/gcc/gcc-13.0.0_pre9999.ebuild b/sys-devel/gcc/gcc-13.0.0_pre9999.ebuild
new file mode 100644
index 000000000000..c3692a55cf5a
--- /dev/null
+++ b/sys-devel/gcc/gcc-13.0.0_pre9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+TOOLCHAIN_GCC_PV=13.0.0
+
+PATCH_VER="5"
+PATCH_GCC_VER="12.0.0"
+MUSL_VER="4"
+MUSL_GCC_VER="12.0.0"
+
+inherit toolchain
+# Needs to be after inherit (for now?), bug #830908
+EGIT_BRANCH=master
+
+# Don't keyword live ebuilds
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+
+# Technically only if USE=hardened *too* right now, but no point in complicating it further.
+# If GCC is enabling CET by default, we need glibc to be built with support for it.
+# bug #830454
+RDEPEND="elibc_glibc? ( sys-libs/glibc[cet(-)?] )"
+DEPEND="${RDEPEND}"
+BDEPEND="${CATEGORY}/binutils[cet(-)?]"
+
+src_prepare() {
+ local p upstreamed_patches=(
+ # add them here
+ )
+ for p in "${upstreamed_patches[@]}"; do
+ rm -v "${WORKDIR}/patch/${p}" || die
+ done
+
+ toolchain_src_prepare
+
+ eapply_user
+}