summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-09 15:32:08 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-09 19:36:47 +0200
commitbe3dadf628064390e987f5dee900c10622beb2a2 (patch)
treecac4b6f014b5663136087db26e85c8c4db23994e /sys-devel
parentsys-libs/libomp: Bump to 15.0.0_rc2 (diff)
downloadgentoo-be3dadf628064390e987f5dee900c10622beb2a2.tar.gz
gentoo-be3dadf628064390e987f5dee900c10622beb2a2.tar.bz2
gentoo-be3dadf628064390e987f5dee900c10622beb2a2.zip
sys-devel/clang-runtime: Bump to 15.0.0_rc2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-15.0.0_rc2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-15.0.0_rc2.ebuild b/sys-devel/clang-runtime/clang-runtime-15.0.0_rc2.ebuild
new file mode 100644
index 000000000000..e4ff9326ddcb
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-15.0.0_rc2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"