summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2023-02-02 21:22:26 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2023-02-03 06:28:04 +0100
commit2921d90975df410f80586922b4d531133afbe43e (patch)
tree840a49b0b5ff4be4f09a0bfd9a9e2b03eb164e2b /sys-firmware
parentapp-admin/gkrellm: update HOMEPAGE (diff)
downloadgentoo-2921d90975df410f80586922b4d531133afbe43e.tar.gz
gentoo-2921d90975df410f80586922b4d531133afbe43e.tar.bz2
gentoo-2921d90975df410f80586922b4d531133afbe43e.zip
sys-firmware/raspberrypi-wifi-ucode: add 20221012.1_p1
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/raspberrypi-wifi-ucode/Manifest1
-rw-r--r--sys-firmware/raspberrypi-wifi-ucode/raspberrypi-wifi-ucode-20221012.1_p1.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/sys-firmware/raspberrypi-wifi-ucode/Manifest b/sys-firmware/raspberrypi-wifi-ucode/Manifest
index 2884a3943e8c..5a473667bb89 100644
--- a/sys-firmware/raspberrypi-wifi-ucode/Manifest
+++ b/sys-firmware/raspberrypi-wifi-ucode/Manifest
@@ -1,3 +1,4 @@
DIST firmware-nonfree_20190114-1+rpt11.debian.tar.xz 2038892 BLAKE2B a2d66e637cd26928c23855f5369c13b83e25b6b4353c82e9a62cb14b010a8c1fda566f6d200e0e7a706c7fb140238082238b7af80fe1f75fe3f07c815fc0eb6a SHA512 5ba6783dc3f3903f20321571a1fb2e11d7781de6d49689c68e6e1f194dad9cdddec90abc94a32a130323b2c8f9839af387c46aee895caf30ffb2f6dfe6d95b7d
DIST firmware-nonfree_20210315-3+rpt5.debian.tar.xz 1743300 BLAKE2B 5de090eefc68ba34df43c58a08554891b8e98d1c8ebce37c63275af8ca438b42880d95dcddf902a1491e19007ccab8cec950f74f50c4f84df092c76e6ffb437b SHA512 8a2151b8c96b0ba806eb25fb0eed12c3b3b91d3386f8ed4ab8058dc5c5989ed5eee39c8c24ceaa8f343042a5031a8c4a2cd759b42cb12d76b58209de50c44083
DIST firmware-nonfree_20210315-3+rpt7.debian.tar.xz 1755320 BLAKE2B d7d5a3a2a1f7fbf6f18c751a92012bb7018aab403091288c291d64dbc7c46b26053f3d8693253625d7603a3df9ef9ec8e5f27c365dd0e0904725f351c54931a7 SHA512 e0ae23a0306d941d0633be19e964dbaf657fe64d97bf767691558e8565814f71dbd4f45dad8219ccc8a8953bc8088f8a98e65a11d389e0d0868bf20349060ded
+DIST firmware-nonfree_20221012-1~bpo11+1+rpt1.debian.tar.xz 1819844 BLAKE2B 3b8bea16b73b67f8467844c282f337ac4784a937a54e05b255d2bb7956a2ee10f6a4cdb619384e7d408df4d637d5a3e9b1a50bb260ac3afd22e23dee8177ed21 SHA512 ba25ea62096bcac853865ff28d0982c05c37a364e10e846984d14c30ae7441cfd0b35a7c6bf4bfeca5aa5b2321e582b8e7553cdf28dd919371227fb8550c541b
diff --git a/sys-firmware/raspberrypi-wifi-ucode/raspberrypi-wifi-ucode-20221012.1_p1.ebuild b/sys-firmware/raspberrypi-wifi-ucode/raspberrypi-wifi-ucode-20221012.1_p1.ebuild
new file mode 100644
index 000000000000..11cfc86d0710
--- /dev/null
+++ b/sys-firmware/raspberrypi-wifi-ucode/raspberrypi-wifi-ucode-20221012.1_p1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Most up-to-date uCode for the Broadcom wifi chips on Raspberry Pi SBCs"
+HOMEPAGE="
+ https://github.com/RPi-Distro/firmware-nonfree
+ https://archive.raspberrypi.org/debian/pool/main/f/firmware-nonfree"
+MY_PN=firmware-nonfree
+SRC_URI="https://archive.raspberrypi.org/debian/pool/main/f/${MY_PN}/${MY_PN}_$(ver_cut 1)-$(ver_cut 2)~bpo11+1+rpt$(ver_cut 4).debian.tar.xz"
+S="${WORKDIR}"
+
+LICENSE="Broadcom"
+SLOT="0"
+KEYWORDS="~arm ~arm64"
+
+RDEPEND="
+ net-wireless/wireless-regdb
+ !sys-kernel/linux-firmware[-savedconfig]
+"
+
+pkg_pretend() {
+ local -a BADFILES=()
+ local txt file
+ # /lib/firmware/brcm/brcmfmac434{30,36,55,56}-sdio.*.txt
+ # The above pattern works because the files we want to hit
+ # have names of the form:
+ # * /lib/firmware/brcm/brcmfmac43430-sdio.AP6212.txt
+ # * /lib/firmware/brcm/brcmfmac43430-sdio.Hampoo-D2D3_Vi8A1.txt
+ # * /lib/firmware/brcm/brcmfmac43430-sdio.MUR1DX.txt
+ # * /lib/firmware/brcm/brcmfmac43430-sdio.raspberrypi,3-model-b.txt
+ # * /lib/firmware/brcm/brcmfmac43455-sdio.MINIX-NEO Z83-4.txt
+ # * /lib/firmware/brcm/brcmfmac43455-sdio.raspberrypi,3-model-a-plus.txt
+ # * /lib/firmware/brcm/brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt
+ # * /lib/firmware/brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt
+ # While the files installed by raspberrypi-wifi-ucode have names
+ # of the form:
+ # * /lib/firmware/brcm/brcmfmac43430-sdio.txt
+ # * /lib/firmware/brcm/brcmfmac43436-sdio.txt
+ # * /lib/firmware/brcm/brcmfmac43455-sdio.txt
+ # * /lib/firmware/brcm/brcmfmac43456-sdio.txt
+ # So no overlap is assured.
+ for txt in "${EPREFIX}"/lib/firmware/brcm/brcmfmac434{30,36,55,56}-sdio.*.txt; do
+ [[ -e "${txt}" ]] && BADFILES+=( "${txt}" )
+ done
+
+ if [[ "${#BADFILES[@]}" -gt 1 ]]; then
+ eerror "The following files should be excluded from the savedconfig of"
+ eerror "linux-firmware and linux-firmware should be re-emerged. Even"
+ eerror "though they do not collide with files from ${PN},"
+ eerror "they may be loaded preferentially to the files included in"
+ eerror "${PN}, leading to undefined behaviour."
+ eerror "List of files:"
+ for file in "${BADFILES[@]}"; do
+ eerror "${file}"
+ done
+ fi
+}
+
+src_configure() {
+ unlink "${S}"/debian/config/brcm80211/brcm/brcmfmac43455-sdio.bin || die
+ ln -rs \
+ "${S}"/debian/config/brcm80211/cypress/cyfmac43455-sdio-standard.bin \
+ "${S}"/debian/config/brcm80211/brcm/brcmfmac43455-sdio.bin || die
+
+ ln -frs \
+ "${S}"/debian/config/brcm80211/cypress/cyfmac43455-sdio-standard.bin \
+ "${S}"/debian/config/brcm80211/brcm/brcmfmac43455-sdio.raspberrypi,3-model-a-plus.bin
+
+ ln -frs \
+ "${S}"/debian/config/brcm80211/cypress/cyfmac43455-sdio-standard.bin \
+ "${S}"/debian/config/brcm80211/brcm/brcmfmac43455-sdio.raspberrypi,3-model-b-plus.bin
+
+ ln -frs \
+ "${S}"/debian/config/brcm80211/cypress/cyfmac43455-sdio-standard.bin \
+ "${S}"/debian/config/brcm80211/brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.bin
+}
+
+src_install() {
+ insinto /lib/firmware/brcm
+ doins debian/config/brcm80211/brcm/*
+
+ insinto /lib/firmware/cypress
+ doins debian/config/brcm80211/cypress/*
+
+ dodoc debian/changelog
+}