summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-04-24 18:50:49 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-24 18:50:49 +0200
commit441c26374b07d44e3a836209dd79eebe7b094325 (patch)
tree3f0d9a229b445ca1662019323773106cf643492e /sys-firmware
parentsys-firmware/ipxe: EAPI 7 (diff)
downloadgentoo-441c26374b07d44e3a836209dd79eebe7b094325.tar.gz
gentoo-441c26374b07d44e3a836209dd79eebe7b094325.tar.bz2
gentoo-441c26374b07d44e3a836209dd79eebe7b094325.zip
sys-firmware/ipxe: [QA] Add missing || die and canonical ordering
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/ipxe/ipxe-1.21.1.ebuild29
1 files changed, 16 insertions, 13 deletions
diff --git a/sys-firmware/ipxe/ipxe-1.21.1.ebuild b/sys-firmware/ipxe/ipxe-1.21.1.ebuild
index fbc44c9ad9b5..bfa23b68a2e7 100644
--- a/sys-firmware/ipxe/ipxe-1.21.1.ebuild
+++ b/sys-firmware/ipxe/ipxe-1.21.1.ebuild
@@ -10,15 +10,16 @@ HOMEPAGE="https://ipxe.org/"
SRC_URI="
!binary? ( https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz )
binary? ( https://dev.gentoo.org/~tamiko/distfiles/${P}-bin.tar.xz )"
+S="${WORKDIR}/${P}/src"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86"
IUSE="+binary efi ipv6 iso lkrn +qemu undi usb vmware"
-
REQUIRED_USE="!amd64? ( !x86? ( binary ) )"
-SOURCE_DEPEND="app-arch/xz-utils
+SOURCE_DEPEND="
+ app-arch/xz-utils
dev-lang/perl
iso? (
app-cdr/cdrtools
@@ -30,23 +31,25 @@ BDEPEND="
x86? ( ${SOURCE_DEPEND} )
)"
-S="${WORKDIR}/${P}/src"
-
src_configure() {
use binary && return
- cat <<-EOF > "${S}"/config/local/general.h
-#undef BANNER_TIMEOUT
-#define BANNER_TIMEOUT 0
-EOF
+ cat > config/local/general.h <<-EOF || die
+ #undef BANNER_TIMEOUT
+ #define BANNER_TIMEOUT 0
+ EOF
- use ipv6 && echo "#define NET_PROTO_IPV6" >> "${S}"/config/local/general.h
+ if use ipv6; then
+ cat >> config/local/general.h <<-EOF || die
+ #define NET_PROTO_IPV6
+ EOF
+ fi
if use vmware; then
- cat <<-EOF >> "${S}"/config/local/general.h
-#define VMWARE_SETTINGS
-#define CONSOLE_VMWARE
-EOF
+ cat >> config/local/general.h <<-EOF || die
+ #define VMWARE_SETTINGS
+ #define CONSOLE_VMWARE
+ EOF
fi
restore_config config/local/general.h