summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/diskdev_cmds
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/diskdev_cmds')
-rw-r--r--sys-fs/diskdev_cmds/Manifest3
-rw-r--r--sys-fs/diskdev_cmds/diskdev_cmds-332.14.ebuild41
-rw-r--r--sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild47
-rw-r--r--sys-fs/diskdev_cmds/files/diskdev_cmds-respect-cflags.patch9
-rw-r--r--sys-fs/diskdev_cmds/metadata.xml14
5 files changed, 114 insertions, 0 deletions
diff --git a/sys-fs/diskdev_cmds/Manifest b/sys-fs/diskdev_cmds/Manifest
new file mode 100644
index 000000000000..7619d2dce49d
--- /dev/null
+++ b/sys-fs/diskdev_cmds/Manifest
@@ -0,0 +1,3 @@
+DIST diskdev_cmds-332.14.patch.bz2 40477 SHA256 695889250a1faad15d841f86d62af49b492e4db792d683d21c99340e3a35e68a
+DIST diskdev_cmds-332.14.tar.gz 714035 SHA256 a46bec392661a02d9683355baf4442d494e2bcde0ffb094aacc1e57ddc03b3d4 SHA512 e1df91fb5330dc01a79de99dd8b1f389a337a19c2136994d59b7cbca9c2e1cb5f7d47101366dd01db4e23a5d3d7afab41758045bf7402d739fa22182dc922044 WHIRLPOOL bb39c2949c7b05ca82301894954ccd726b5c962d6af61bf04c7e262de3304e788f38c392e8dd526d1038f9389c42033993ca8feb708fd94b7e94fd958db9728e
+DIST diskdev_cmds-332.14_p1.patch.bz2 21989 SHA256 8e6889b318b1015e9be13dc12b3694c8e7077428a1142fbeb503609771f49bda SHA512 aaef096aa6a3f2e09bcc8c1831172c3d68994589ade505153ade00e6f4d0c49263b63212f8616ece597b1ee218a87474bb1c3812d15f34c5bc5c51fd7b72a062 WHIRLPOOL efca536f9c5dcb8308945731094227f7b12b23b0f930a4d88add7780b4f9206631653d9ef008572936426a6fb5641393bd3ff39a393f66e88f6558584f7439e1
diff --git a/sys-fs/diskdev_cmds/diskdev_cmds-332.14.ebuild b/sys-fs/diskdev_cmds/diskdev_cmds-332.14.ebuild
new file mode 100644
index 000000000000..7e52817910dd
--- /dev/null
+++ b/sys-fs/diskdev_cmds/diskdev_cmds-332.14.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="HFS and HFS+ utils ported from OSX, supplies mkfs and fsck"
+HOMEPAGE="http://opendarwin.org"
+SRC_URI="http://darwinsource.opendarwin.org/tarballs/apsl/diskdev_cmds-${PV}.tar.gz
+ mirror://gentoo/diskdev_cmds-${PV}.patch.bz2"
+LICENSE="APSL-2"
+SLOT="0"
+KEYWORDS="-amd64 ~ppc ~x86"
+IUSE=""
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/diskdev_cmds-${PV}.patch
+}
+
+src_compile() {
+ emake -f Makefile.lnx || die "emake failed"
+}
+
+src_install() {
+ exeinto /sbin
+ doexe fsck_hfs.tproj/fsck_hfs
+ doexe newfs_hfs.tproj/newfs_hfs
+ dosym /sbin/newfs_hfs /sbin/mkfs.hfs
+ dosym /sbin/newfs_hfs /sbin/mkfs.hfsplus
+ dosym /sbin/fsck_hfs /sbin/fsck.hfs
+ dosym /sbin/fsck_hfs /sbin/fsck.hfsplus
+ doman newfs_hfs.tproj/newfs_hfs.8
+ newman newfs_hfs.tproj/newfs_hfs.8 mkfs.hfs.8
+ newman newfs_hfs.tproj/newfs_hfs.8 mkfs.hfsplus.8
+ doman fsck_hfs.tproj/fsck_hfs.8
+ newman fsck_hfs.tproj/fsck_hfs.8 fsck.hfs.8
+ newman fsck_hfs.tproj/fsck_hfs.8 fsck.hfsplus.8
+}
diff --git a/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild b/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild
new file mode 100644
index 000000000000..8b1a4dd12615
--- /dev/null
+++ b/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_PV=${PV%_p*}
+
+DESCRIPTION="HFS and HFS+ utils ported from OSX, supplies mkfs and fsck"
+HOMEPAGE="http://opendarwin.org"
+SRC_URI="http://darwinsource.opendarwin.org/tarballs/apsl/diskdev_cmds-${MY_PV}.tar.gz
+ mirror://gentoo/diskdev_cmds-${PV}.patch.bz2"
+LICENSE="APSL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE=""
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/diskdev_cmds-${PV}.patch
+ epatch "${FILESDIR}"/diskdev_cmds-respect-cflags.patch
+}
+
+src_compile() {
+ emake -f Makefile.lnx || die "emake failed"
+}
+
+src_install() {
+ into /
+ dosbin fsck_hfs.tproj/fsck_hfs || die "dosbin fsck failed"
+ dosbin newfs_hfs.tproj/newfs_hfs || die "dosbin newfs failed"
+ dosym /sbin/newfs_hfs /sbin/mkfs.hfs || die "dosym mkfs.hfs failed"
+ dosym /sbin/newfs_hfs /sbin/mkfs.hfsplus || die "dosym mkfs.hfsplus failed"
+ dosym /sbin/fsck_hfs /sbin/fsck.hfs || die "dosym fsck.hfs failed"
+ dosym /sbin/fsck_hfs /sbin/fsck.hfsplus || die "dosym fsck.hfsplus failed"
+ doman newfs_hfs.tproj/newfs_hfs.8 || die "doman newfs_hfs.8 failed"
+ newman newfs_hfs.tproj/newfs_hfs.8 mkfs.hfs.8 || die "doman mkfs.hfs.8 failed"
+ newman newfs_hfs.tproj/newfs_hfs.8 mkfs.hfsplus.8 || die "doman mkfs.hfsplus.8 failed"
+ doman fsck_hfs.tproj/fsck_hfs.8 || die "doman fsck_hfs.8 failed"
+ newman fsck_hfs.tproj/fsck_hfs.8 fsck.hfs.8 || die "doman fsck.hfs.8 failed"
+ newman fsck_hfs.tproj/fsck_hfs.8 fsck.hfsplus.8 || die "doman fsck.hfsplus.8 failed"
+}
diff --git a/sys-fs/diskdev_cmds/files/diskdev_cmds-respect-cflags.patch b/sys-fs/diskdev_cmds/files/diskdev_cmds-respect-cflags.patch
new file mode 100644
index 000000000000..3f939f61163a
--- /dev/null
+++ b/sys-fs/diskdev_cmds/files/diskdev_cmds-respect-cflags.patch
@@ -0,0 +1,9 @@
+--- Makefile.lnx.bak 2009-07-22 11:58:10.000000000 -0400
++++ Makefile.lnx 2009-07-22 11:57:37.000000000 -0400
+@@ -1,5 +1,5 @@
+ CC := gcc
+-CFLAGS := -g3 -Wall -I$(PWD)/include -DDEBUG_BUILD=0 -D_FILE_OFFSET_BITS=64 -D LINUX=1 -D BSD=1
++CFLAGS += -Wall -I$(PWD)/include -DDEBUG_BUILD=0 -D_FILE_OFFSET_BITS=64 -D LINUX=1 -D BSD=1
+ SUBDIRS := newfs_hfs.tproj fsck_hfs.tproj
+
+ all clean:
diff --git a/sys-fs/diskdev_cmds/metadata.xml b/sys-fs/diskdev_cmds/metadata.xml
new file mode 100644
index 000000000000..e2ceeff332bf
--- /dev/null
+++ b/sys-fs/diskdev_cmds/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ppc</herd>
+<maintainer>
+<email>josejx@gentoo.org</email>
+<name>Joseph Jezak</name>
+</maintainer>
+<longdescription lang="en">
+HFS+ Filesytstem tools (mkfs.hfsplus and fsck.hfsplus), ported from Apple's
+versions.
+</longdescription>
+</pkgmetadata>
+