summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorIgor Savlook <isav@alzari.pw>2017-08-13 22:44:54 +0300
committerCraig Andrews <candrews@gentoo.org>2017-12-20 17:53:15 -0500
commit091370ab89714574974f0de3dba57a63e205a9f5 (patch)
tree9704bcdda21e59817102e9c6141334da946c4a08 /sys-fs
parentnet-nntp/slrn: Use https for SRC_URI (diff)
downloadgentoo-091370ab89714574974f0de3dba57a63e205a9f5.tar.gz
gentoo-091370ab89714574974f0de3dba57a63e205a9f5.tar.bz2
gentoo-091370ab89714574974f0de3dba57a63e205a9f5.zip
sys-fs/cryptmount: lvm2 package is needed to compile
Also fix email in metadata.xml Closes: https://bugs.gentoo.org/625550
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptmount/cryptmount-5.2.2-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-fs/cryptmount/cryptmount-5.2.2-r1.ebuild b/sys-fs/cryptmount/cryptmount-5.2.2-r1.ebuild
new file mode 100644
index 000000000000..690f70da85bb
--- /dev/null
+++ b/sys-fs/cryptmount/cryptmount-5.2.2-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd
+
+DESCRIPTION="A utility for management and user-mode mounting of encrypted filesystems"
+HOMEPAGE="http://cryptmount.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="nls +ssl systemd"
+
+DOCS=( AUTHORS ChangeLog NEWS README RELNOTES ToDo )
+
+RDEPEND="
+ dev-libs/libgcrypt:0=
+ sys-fs/lvm2:0=
+ nls? ( virtual/libintl )
+ ssl? ( dev-libs/openssl:0= )
+ systemd? ( sys-apps/systemd )"
+
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+CONFIG_CHECK="BLK_DEV_DM"
+ERROR_BLK_DEV_DM="Please enable Device mapper support in your kernel config
+ -> Device Drivers
+ -> Multi-device support (RAID and LVM)
+ -> Multiple devices driver support (RAID and LVM) (MD)
+ <M> Device mapper support"
+
+src_configure() {
+ econf \
+ --enable-cswap \
+ --enable-delegation \
+ --enable-fsck \
+ --enable-luks \
+ --with-libgcrypt \
+ $(use_enable nls) \
+ $(use_enable ssl openssl-compat) \
+ $(use_with systemd)
+}
+
+src_install() {
+ default
+}