summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-14 23:02:45 +0000
committerSam James <sam@gentoo.org>2022-02-14 23:03:46 +0000
commit6b99e097079e6004edf0b0be0a9b314796af461d (patch)
tree95ec47ba7c8e204dbc0d395e08af41498d4d2dfc /sys-fs
parentsys-fs/xfsdump: add 3.1.10 (diff)
downloadgentoo-6b99e097079e6004edf0b0be0a9b314796af461d.tar.gz
gentoo-6b99e097079e6004edf0b0be0a9b314796af461d.tar.bz2
gentoo-6b99e097079e6004edf0b0be0a9b314796af461d.zip
sys-fs/xfsdump: drop 3.1.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xfsdump/xfsdump-3.1.9.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/sys-fs/xfsdump/xfsdump-3.1.9.ebuild b/sys-fs/xfsdump/xfsdump-3.1.9.ebuild
deleted file mode 100644
index f89dc7dcba2b..000000000000
--- a/sys-fs/xfsdump/xfsdump-3.1.9.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="xfs dump/restore utilities"
-HOMEPAGE="https://xfs.wiki.kernel.org/"
-SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ppc ppc64 -sparc x86"
-IUSE="ncurses nls"
-
-RDEPEND="
- >=sys-apps/attr-2.4.19
- sys-apps/dmapi
- sys-apps/util-linux
- sys-fs/e2fsprogs
- >=sys-fs/xfsprogs-3.2.0
- ncurses? ( sys-libs/ncurses:0= )
-"
-DEPEND="${RDEPEND}
- nls? (
- sys-devel/gettext
- )
-"
-BDEPEND="ncurses? ( virtual/pkgconfig )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.1.9-prompt-overflow.patch #335115
- "${FILESDIR}"/${PN}-3.1.9-no-symlink.patch #311881
- "${FILESDIR}"/${PN}-3.1.6-linguas.patch #561664
- "${FILESDIR}"/${PN}-3.1.9-fix-docs.patch
- "${FILESDIR}"/${PN}-3.1.9-skip-inventory-debian-subfolder.patch
-)
-
-src_prepare() {
- sed -i \
- -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
- include/builddefs.in \
- || die
-
- sed -i \
- -e "s:enable_curses=[a-z]*:enable_curses=$(usex ncurses):" \
- -e "s:libcurses=\"[^\"]*\":libcurses='$(use ncurses && $(tc-getPKG_CONFIG) --libs ncurses)':" \
- configure || die #605852
-
- default
-}
-
-src_configure() {
- unset PLATFORM #184564
- export OPTIMIZER=${CFLAGS}
- export DEBUG=-DNDEBUG
-
- local myeconfargs=(
- $(use_enable nls gettext)
- --libdir="${EPREFIX}/$(get_libdir)"
- --libexecdir="${EPREFIX}/usr/$(get_libdir)"
- --sbindir="${EPREFIX}/sbin"
- )
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- # enable verbose build
- emake V=1
-}